Jandy colors pool light not working and iAqualink vs Autelis

jpcdmd

Member
Nov 7, 2007
24
1. My JandyColors pool light suddenly stopped working. Its was working fine several nights then stopped completely. Bulbs are only two years old and haven't been used much since then. Removed light from niche to replace gasket, all bulb filaments look ok. Very very minor amount of condensation on inside of lens. Tested light while on pool deck, no luck. I have the Jandy Aqualink with sub panel and GFCI knockout. Light wiring is wired to back of GFCI outlet. The GFCI outlet also has my landscape light transformer plugged into it. Landscape lights work fine. The GFCI will not hold the Reset button. Pressing Test button trips the landscape lights off. I can hear the relay tripping in the Jandy Aqualink Powercenter when I try to turn on the pool light via my PDA controller.
-Could it be the GFCI?
-Should I consider replacing the pool light with the niche cover/nicheless LED lights or the direct-fit standard Pool LED light? (so I don't have to replace the halogen bulbs in the future)

2. I hate using my Jandy PDA remote and noticed the new iAqualink and Autelis systems. I currently have an AqualinkRS and PDA-P8 (pool only) from ~2007. PDA only, no RS One-Touch or interior control panel. The PDA says Firmware PPD: PDA 1.2, J-box 1.29, Handheld 3.0. I would like to be able to control my pool system from my Android phone.
-Should I upgrade to the iAqualink system or Autelis? Will I need the Jandy IQ900RS or the IQ900? Is the Autelis system any better?
Thanks
IMAG4540_zpsaeae284d.jpg

IMAG4541_zpsb0af9a55.jpg
 
Last edited:

tomfinch

Well-known member
Mar 11, 2012
52
Las Vegas, NV
I just had an issue with my relay being bad even though you can hear it click. Swapped the lights to a different relay and all is well. I used a voltage meter to test the relay.
 

jpcdmd

Member
Nov 7, 2007
24
I just had an issue with my relay being bad even though you can hear it click. Swapped the lights to a different relay and all is well. I used a voltage meter to test the relay.

I will try this. I have a few spare Jandy relays sitting around.
 

jpcdmd

Member
Nov 7, 2007
24
So I moved the power wires for the pool light to another AUX relay in the Power Center junction box and it still will not work. The GFCI outlet still won't hold the reset button, even with the light sitting on the pool deck, out of the water, with the lens removed. Is it possible the GFCI outlet is broken but still able to power the plug for the landscape light transformer?
BTW, when I removed the lens and tried reassembling it, I could not get the ring clamp back on the light. What a total PITA! So I left it disassembled, and purchased two of the new Jandy LED Nicheless lights and the Jandy Niche Cover to mount them on. I'm getting rid of this P.O.S....working or not. At least I won't ever have to buy replacement halogen bulbs and disassemble the **** thing ever again.

Oh and I also purchased and installed the iAqualink IQ900RS. Installation took about an hour, was pretty easy. Took me a while to figure out how to program it but I got it down. Just have to mount the antenna on the wall of the house. I'm having trouble viewing their iaqualink.com internet page from my laptop, appears their server's certificate has issues. Will not work in either Google Chrome or IE.
 

jpcdmd

Member
Nov 7, 2007
24
I replaced the GFCI and replaced the pool light with the new Jandy Watercolors LED 120V light. At first I had the new GFCI wired incorrectly because the LINE and LOAD poles were opposite of the old one I removed. But after redoing the GFCI wiring correctly, I still cannot get the pool light to work. The landscape lights are plugged into the new GFCI and work fine, and the new GFCI is not tripping like the old one. I just cannot get the pool light to turn on. I hear the relay clicking several times when I use the iAqualink to try to turn on the light, as it is "cycling" to a requested color. I am testing the pool light with it sitting on the deck. I have not gotten it wet yet. I'm stumped.

BTW, I had an electrician out here to install the light and apparently it was too early in the season, he wasn't entering pools yet. He told me it was a simple job and that I could do it myself so I did, and yes it was not hard at all.

EDITED: I installed the light in the niche, so it is wet and grounded to the niche. Still not working. The only other thing I could do would be to replace the 15A breaker, but I don't think its malfunctioning since the GFCI is providing power to the landscape lighting plug.
 

jpcdmd

Member
Nov 7, 2007
24
Well the Jandy light started working last night at dusk. I was out hosing the deck off and noticed the light was on. However, it would not respond to requests to change color, nor could I get it to turn off/on. Using the iAqualink, when I tried changing the color, the aqualink RS PCB was doing its job and the AUX2 relay was clicking on/off to cycle through the colors, but the light was not responding...it would just stay on the same color. To get it to change color, I had to manually flip the breaker switch in the aqualink j-box. This would also kill the landscape lights as well, because my landscape lighting transformer is plugged into the GFCI that monitors the pool light. The PCB, AUX relay, and GFCI are all brand new. I turned the light off via iaqualink this morning before I left for work but did not check to see if the light had actually turned off in the pool. I have the DUSK SETUP set to DISABLED in the iaqualink settings.
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.