Jandy Aquapure / Nature2 Error 120 - check my troubleshooting

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Hey folks.

Hope you're having a good long weekend!

Just wanted to double check my logic here and tag on a couple of extra questions.

Getting Error 120 on my SWG, although it is still generating ok for now.

Visual inspection of cell looks good. The 3 prongs at the top look ok, middle one a hint more wear but not terrible. Cable also looks ok but a little bit of corrosion on the center socket.

Checked current - getting 5.5A in one direction and in the other it started at 4.45 but over the course of 5 minutes or so degraded to 4.1A. So the code seems valid.

Salt level is actually 3200 (K-1766), but reading 3600-3800 on the panel. Curious because I thought that salt would start to read low when the cell failed?

Anyway, my questions:

1) Have I missed anything? Anything else to try?

2) Is it worth trying a replacement cable first, or is the uneven amperage enough proof that the cell itself is at fault? The one I have has 3 physical wires inside, but 2 are paralleled at the controller end, so I don't think it's possible for there to be uneven current?

3) Does anybody know if the Aquapure cells are the same plumbing dimensions as the Nature2? The floor around the unit is damp so I suspect a small leak in the housing, and since the mineral cartridge has been removed a direct swap for the regular Aquapure would be helpful - and better for replacement parts as it's a bit more common. It would be great if I could swap it in on the old unions without having to do new plumbing. I believe the board and sensors etc. are all the same?

Thanks!
 
Last edited:

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
A polite bump as I would really appreciate some input on this, especially from resident expert @JamesW who knows these units inside and out - literally! :)
 

JamesW

TFP Expert
Mar 2, 2011
28,262
 

thegizzard

Active member
May 9, 2021
43
Charlotte, NC
Pool Size
19300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
I believe the thinking is the Nature 2 Fusion Soft Salt Cell and Aqua Pure Salt cell are the same mechanically. But the form factor is different. You cannot use the Nature 2 Salt Cell in an Aqua Pure system and vice versa.
 

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
I believe the thinking is the Nature 2 Fusion Soft Salt Cell and Aqua Pure Salt cell are the same mechanically. But the form factor is different. You cannot use the Nature 2 Salt Cell in an Aqua Pure system and vice versa.
Do you mean 'the same electronically'?

Totally understand that they are different form factor and the cells themselves are not compatible - I'm just wondering whether I can re-plumb onto the existing unions or if I'd need to do some PVC work too if I went down that route.
 

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Yup read through that thread - lots of good advice in there and lots of weird issues that I recognize (even the 'Aquapure disappearing from the PDA but comes back if you power cycle pump' issue). Results of current tests are posted in my OP.

It's seemingly intermittent so hard to chase right now. The two questions I don't believe are answered are:

1) Whether the Nature2 and Aquapure would fit onto the same unions (footprint); and
2) Whether a replacement cable could ever help, given the uneven current I'm seeing.I would have thought that a cable issue would cause uneven current for both flow directions?

Thank you!
 

JamesW

TFP Expert
Mar 2, 2011
28,262
  • Like
Reactions: BenB

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Amazing - thank you for knowing your way around their site so well!!

Can't decide which of these is most appropriate?

1631123093449.png or 1631123128468.png

Either way, thanks!
 

JamesW

TFP Expert
Mar 2, 2011
28,262
You can try a new cable, but I think that the chances of it helping are very low.

How old is the cell?

Can you pull the cell and check it for scale and check the parts for corrosion?

What is the first part of the serial number?

This image from a previous thread shows heavy scaling, which might be the issue.

You can try cleaning the cell if it has scale.

1631123224463.png
 

Enjoying this content?

Support TFP with a donation.

Give Support

BenB

Gold Supporter
Jul 24, 2020
269
San Jose, CA
Pool Size
19500
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
Visual inspection is good. When we moved here in July 2020 the cell looked like the picture (ha! I just realized in looking for a pic to compare that that picture is literally one of my cell from a previous thread!), but since cleaning it (5:1 MA) it has remained completely clear - funny how keeping the water to TFP standards will do that....! However, I concede that the time the cell spent heavily scaled, and the subsequent 'harsh' clean may have shortened its life.

I will need to pull it out again to check serial number. The previous owners did not give a clear indication of age but I doubt it would be under warranty - I suppose no harm in trying if the serial indicates a recent year.

I'm inclined to let it limp through the rest of the season given it's still producing, and replace in the springtime with the Aquapure or compatible cell now we know it fits! The new cell will come with a cable anyway so at least I'd be starting fresh with both parts when the time comes.
 
  • Like
Reactions: JamesW
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread