Jandy AquaLink RS PDA, Lemon, or just bad programming?

JerryVenturaCA

New member
Jul 19, 2010
3
Back in December of 2009 I had a Jandy AquaLink RS PDA system, with a Jandy ePump and Jandy Purelink 700 cell installed. They did a great job of taking my old equipment out and arranging the new equipment back in, they even fixed some very dangerous installations the original owners contractor had done. Like no grounding wire to the lights etc. Problems started right away, I am retired so I was around a lot to catch some of these things going wrong. The PDA would just freeze. As the windows rotated from one screen to the next sometimes the screens would just meld together, or just not show up. I have it programmed to be at one speed for filtration and speed up for four hours to run the cleaner. Sometimes it runs at the wrong speeds at the wrong times. It used to gear up or down while in the spa when the heater would come on or off, they found a programming solution that wasn't in the manual. Now I'm good with computers and I would run through all the menus trying to figure out some of this stuff, this system is so over kill I'm sure much of it is just conflicting with it's self. The pool contractor has been great, and believed me, but Jandy kept saying this could not be happening. As more systems are installed they started finding some of this out. Anyway, to wrap this up, because I could write a book. When the system runs, it's great and I couldn't be happier, but it never runs great for long. Jandy changed part of the computer board, but things still keep happening. I think it's a lemon, and I think they need to start from scratch and redo there programming system. If anyone would like I have recorded with my phone a couple video's of a couple things, there are four video's of just what I've been dealing with since yesterday, the system is gone berzerk! My YouTube page is under (what else) JerryVenturaCa. Any and all opinions and suggestions on how I should deal with this would be much appreciated.
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
Welcome to TFP!

Some of what you describe sounds like communication problems between the PDA and the main unit, which could happen from a defective or improperly installed antenna on the main unit. However, Jandy tech support is usually quite good at figuring out an antenna problem, so it seems likely that there is something else going wrong as well.
 

JerryVenturaCA

New member
Jul 19, 2010
3
Well you were partly right, turns out the antenna went bad. That took care of the PDA, so it's communicating now. There is still a problem with the pump speeds being wrong at times, but it seems to correct it's self the next day when it turns on for a new cycle. Jandy still doesn't like to admit to any problems so I've started using video to document all these malfunctions. My pool contractor, although very frustrated, has been really good about trying to get to the bottom of this. He keeps buggin Jandy, and he keeps coming around trying to make things right.
 

JerryVenturaCA

New member
Jul 19, 2010
3
Just to keep anyone that is interested in Jandy equipment informed: I'm going into 9 months of my new system still not working right. The speeds still are wrong at times, sometimes when I turn the spa on the motor is running while the valves turn even know it is set not to, the ePump went offline for no apparent reason for awhile, the Purellink cell still is not working correctly, a lot of times it reads no flow when there is, it has always read 400-500 over the correct saline level, now it is reading so high its turning off. The saline level is testing at 3200, the cell is reading around 3900-4200, which means when it hits 4100 it doesn't produce any chlorine, and my pool turns green. The cell is clean, and the sensors are also clean. So the saga continues.
 

SJR

New member
Nov 12, 2012
3
My Aqualink PDA is stuck on "waiting"

Inside the J-Box, only the Red Light is on (although the Green Light will flash sometimes)

How can this be fixed?
 

Other Threads of Interest