Jandy/Aqualink New Install

lotuspool

New member
Jun 7, 2021
4
Santa Clarita, Ca
Hi Everyone,


Wanted to get some assistance and advice on a new Jandy Heater and Aqualink system. About 45 days now we had our pool service company install a JXi™ POOL & SPA HEATER and a iaqualink iq20 automation system. Since installation, the system has not worked properly.

The pump is existing and so is filter. The pump is a Intelliflo FSF, about 5 years old

Issues so far
Initially the heater was not working in spa mode.
Pool service company got Jandy involved. Jandy tech came out. Made things worse. Now it did not connect to the internet. It showed up as connected on the web portal, but you could not access the controls. Our pool service company came back out and found the Jandy tech did not connect the cabling for the wireless correctly. The pool service company connected the wireless back up and got it working. It was the wiring from the module with the antenna to the automation box.
From here it gets worse.

Now the heater will not turn on. It is saying “check flow”. When I select from the phone app “spa” the heater does not turn on and the spa sometimes does and does not turn on. It will not turn back to “pool” mode. If I set the automation panel to manual and set everything myself it does not work properly either. The heater also stays on “spa” instead of switching to “pool”.

I called Jandy many times and only once received a return call. It was a woman who was “just checking”. I was completely confused by the call. Why didn’t I ever get a tech to call back?

I finally got a call from somebody who represented themselves as a Jandy rep. They said all sorts of things about getting it fixed. Initially responded via txt message and then stopped. They said their tech came back out and reported everything fine. When I asked my pool service company why they didn’t tell the jandy rep that the person who came out made things worked they said, “they didn’t know and it must have slipped their mind, too busy”. The incompetent tech reported everything was fine and it was a pump issue. Mind you the automation was NOT working when they left. I couldn’t access anything and it was physically screwed up in the wiring between the antenna part and the automation box.

So we are getting worse. Now the jandy tech will not return my txt messages. I can’t get anyone from Jandy to respond. The pool service company says heater is fine so they will take back the automation system but I’m stuck with the heater.

They are saying it’s the pump not communicating because that is what my pool service person said. The jandy rep said the pump needed extra programing to work since it was a variable flow. My pool service company admitted to never installing a variable flow with a automation system and didn’t know of any additional flow settings that need to be performed. I found on this forum people reporting how its supposed to be set and sent it to him. He could not be bothered reading it.

Current state

Right now, I can get the heater to stop saying “check flow” by increasing the speed of the pump. I disconnect the control cable, set it in manual, and raise the speed to about 3140 rpm.

On the app if I select “spa”, it gets stuck in spa mode. It will not change back to “pool” mode.

The heater stays on spa or does not have pool or spa selected if on the app I choose spa or pool. I must manually press the pool or spa button on the heater. The automation system does not switch it.

Questions or advice on this? Anyone else dealt with this? Again, resolution from pool service company is they will take back the automation system but not the heater. Pool service company says Jandy wont take anything back since their tech reported all is working even though their tech left it in a worse state.

It it matters we are in Santa Clarita, California. Just outside Los Angeles
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
43,687
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
@PoolGate has the most Jandy automation experience here I believe. Let's see if he can provide some guidance.
 

PoolGate

Gold Supporter
TFP Guide
Jun 7, 2017
6,374
Damascus, MD
Pool Size
29000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
There are 2 ways to connect that heater to the Aqualink automation. 1 is the 4 wire connection and the other is simply using the "on/off" (otherwise known as a "fireman's" switch). Which way is yours connected? You should be able to take the front panel off and see if you have something connected to the terminals 1 and 2 (I think). See below for the manual. If you are using automation the heater would need to be set for automation which there should be directions in the manual for.

The 2nd thing is I do not think you can control that pump with Aqualink. It will control the Intelliflo VS or VF. I don't know what the FSF is. Did you already have that pump? If it was me I'd get a VSP Jandy pump and sell that old one.

While you are in there check all dipswitch settings (also in the below manual) and make sure they are set properly. Did they give you the IQ20-a or IQ20-RS package? Does your system say it is PDA based or Aqualink RS? Pics always help!

Jandy is great if you have/had a properly running system and need help with something. If the system was never working and never installed correctly, they expect the installation tech to complete that part.

 
  • Like
Reactions: mknauss

lotuspool

New member
Jun 7, 2021
4
Santa Clarita, Ca
i'm struggling because my installation tech has now abandoned the project. He says its a pump issue, i've asked for a quote to replace the pump and filter. Pump is 5 years old. He will not do either. I also asked the jandy rep to quote all jandy equipment and have not received quotes weeks later. Multiple requests.

the installation tech is taking back the aqualink system. He says that it is at his cost. He says the heater is my problem. I'm obviously in need of a new pool service company. Anyone in the Santa Clarita area thats recommended please send them my way.

I will take a look at the connections. Its been switched between the two options you are referring to. The Jandy tech that came out and the installer have tried that.

Interesting update. At 3440rpm on the pump, the pump is only showing a flow of 31gpm. From what i can tell this is not good. I have some sort of issue with pump flow. I dont know if its the pump or something else. I'm going to contact some pool people I got off of next door app. *****To be clear this is seperate from the automation issue. When I turn on "Spa" it doesn't turn on the spa and same with pool mode. It doesn't turn the heater to pool or spa modes for the respective settings in the aqualink. Before the tech did the installation the pump worked fine. Flow in the pool was incredible.****

Thank you for your responses.
 

lotuspool

New member
Jun 7, 2021
4
Santa Clarita, Ca
another question, what is the best automation system? Who provides great support? I can't get a response from Jandy support. I find it hard to believe they are the best after multiple calls. Being in IT, i also find it odd that a jandy rep doesn't troll these forums or any of the others. This is a great resource.
 

PoolGate

Gold Supporter
TFP Guide
Jun 7, 2017
6,374
Damascus, MD
Pool Size
29000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
another question, what is the best automation system? Who provides great support? I can't get a response from Jandy support. I find it hard to believe they are the best after multiple calls. Being in IT, i also find it odd that a jandy rep doesn't troll these forums or any of the others. This is a great resource.

"Best" is relative. Typically you'd match your variable speed pump and saltwater generator (plus lights) to the automation. Heaters for the most part can work with any automation. What you are working with is an incompatible pump with your automation. For one and 2 speed pumps this doesn't matter since they work by a simple relay. For variable speed pumps, the pump and controller need to actually talk to each other. Jandy doesn't want to spend all day trying to get something to work together that simply isn't compatible. Aqualink is a great tier 1 automation system. It is one of the few with Alexa control. And the only one with variable in 5% increments "on the fly" automated valve adjustments.

Did you ever check the dip switches? They tell aqualink if you have a spa and such.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.