is this a cracked impeller?

coryp

Active member
Nov 6, 2007
41
so, my 2 spd 2hp tristar has been sounding like it's going on the uphill part of a roller coaster just before the drop. i was hoping it was some debris, but found that the white wear ring had just about eaten through the diffuser.


i assume that the impeller was cracked as well, but looking at the inyo image, it seems to look this was factory... on mine, some fins look like continuous plastic and some do not. anyone have experience with this?


IMG_20170702_171427.jpg
looking at more sales images it looks like maybe it's 2 pieces then machined as a unit.... i think i'm just being cheap and trying to get out of $60 for a new impeller... that and i don't seem to be able to find one in stock earlier than the 5th...
 

kadavis

TFP Guide
In The Industry
Apr 5, 2015
1,666
tucson, arizona
Depending on how old the pump is, it looks like a little wear, does the impeller have a screw in the center holding it onto the shaft?
 

coryp

Active member
Nov 6, 2007
41
thanks, sometimes i skimp too much, i'll wait till i can get a hold of all the parts.
 

coryp

Active member
Nov 6, 2007
41
got it all going, as an FYI, the new white wear ring that came with the diffuser is shorter that the one that was factory installed... i triple checked the # on the ring vs the one on the parts list, so i'm hoping it's just been updated. seem to work so far...
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.