Is my new Warrior SE a lemon?

DiverGirl1972

Gold Supporter
Silver Supporter
May 11, 2018
215
Delta, PA
Longish post - sorry... I recently bought a new Warrior SE when our Tigershark died at the start of the season. We had the Tigershark since we bought the home, as the owner was kind enough to leave it behind, so it’s the one I’ve ever owned. I loved that thing. Other than getting hung up on the main drains (like it seems most will do at some point), it did clean my pool, climbing walls and stairs without issue. It spent plenty of time in both the deep end and the shallow end and did its job wonderfully.

As soon as it arrived on May 1st (3 days later), I dropped it in the pool, and none too soon. In addition to the normal spring debris (mini helicopters, some leaves and dirt), May 4th marked the return of our annual ordeal of grackles dropping fecal sacs in and around the pool, patio and backyard..

The way my returns are pointed, all dirt tends to primarily settle into the center area of both the shallow end and the deep end. I ran the robot multiple times that day and noticed that it barely came up to the shallow end and didn’t climb the stairs at all. When it did come up to the shallow end, it would scooch around the outer wall for a bit and then quickly head back to the deep end.

The following day, I ran it a few more times, having to gently pull the cord and guide the robot to piles of debris that it simply was not getting on its own. I eventually got it relatively "clean", though it's short-lived due to the birds. On a plus side, it seems to get stuck on the main drains significantly less than my TS did. The bad news is, it is leaving debris sitting in my shallow end for a couple of days until I go out and guide it to where I want it to go using the cord.

I’ve kept the filters clean (I spray off the filters after each run, not just empty the bag), there is nothing in the impeller and in the past 7 – 10 days, my frustration is increasing. The amount of organic matter (fecal sacs) in my pool is on the heavy side right now due to the birds and the Warrior just doesn’t seem to be up to the task of cleaning the pool. It climbs the walls with no problem, but won't go up the stairs and ignores the center of the pool (primarily in the shallow end). Honestly, the stairs thing is not really a big issue for me, though annoying.

This past Monday, after the robot had run multiples times over multiples days, I snapped a picture of the debris that had been left behind to collect in the shallow end. I brushed the pool, thinking I could push everything down into the deep end, run the robot again, and increase the odds of it getting picked up. Unfortunately, I am now getting organic stains where the debris is being allowed to sit. It seems to go back and forth over clean spots multiple times and misses piles of debris. I’ll also see it head toward a pile of debris in the deep end, and it just seems to blast through it, spreading it, with little actually being vacuumed up.

This thing is a nightmare. If I wanted to micro-manage the vacuum process this closely, I’d buy the equipment and manually vacuum. Has this ever happened to anyone and Is there any chance of it being declared a lemon so that I can return it and buy something else? I’ve had it for two weeks and I’m completely over it. The first picture is the debris in the shallow end and the the second is the staining I now have.Shallow end debris.jpegShallow end staining.jpeg
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
22,794
Bedford, TX
D,

I have three of these types of cleaners, in three pools. In none of them will the robot clean the stairs.. (I knew this going in..) But almost without exception, if I have one dime-sized leaf in the bottom of the pool, it will be gone when the cleaner is done..

I have no idea why yours is not doing the same thing. I would call the seller and see what they say.

When I turn mine on, you can see the surface water moving like a mini volcano caused by the output of the suction motor. Does yours do that?

Thanks,

Jim R.
 

DiverGirl1972

Gold Supporter
Silver Supporter
May 11, 2018
215
Delta, PA
Hi Jim, thanks for the response. Yes, when I turn it on, it moves forward a little bit and you can see water coming out and bubbling at the surface. It then moves backward and stays there for 7 - 10 seconds and then moves on its way.

As I said, the stairs aren't really a major issue. I usually just brush them off real good and let the robot deal with any debris in the pool area. It's just an annoyance that I'm sure wouldn't bother me at all if the pool itself was being kept clean. I've been running my chlorine a bit high to see if those stains will go away and so far, it's not had an effect.

I did reach out to the place I bought it via email on Tuesday and no one ever responded or acknowledged my email, which was a little disappointing. I didn't call initially because I wanted to put my concerns in writing and the store is located in a different time zone, so they weren't open in the morning when I finally hit the wall and decided to see what could be done about this.

This week was busy, so today was my first chance to really circle back on the issue. I'll call later when they're open and see what they say.
 
  • Like
Reactions: Jimrahbe

MITBeta

Well-known member
Does your Dolphin turn? Does it shimmy sideways along the top of the wall?

I just returned my brand new SE because on the first 2 uses it did both of those things, but by Day 2 it had quit doing both. I think it was a problem with the motor that changes the position of the baffle plate which directs the flow of water from the impeller left, right, or straight.

I've been waiting for the replacement for over a week after waiting several days to get through to the shop (in another time zone) that I bought it from. Hoping for better results on robot #2.
 

markayash

Gold Supporter
Mar 21, 2016
3,505
Atlanta Ga
Also check and clean the fan motor. When mine isn’t acting great I always find pinestraw wrapped around it.
Easy 10 minute job to clean
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.