INTEX STRAINER GRID CLOGGING..

Vinnyd0810

Member
May 29, 2019
9
Middletown nj
Moved from here... INTEX STRAINER GRID CLOGGING

Thanks for the reply. I disconnect the hose form the pool skimmer and i plug the bug hose into the adapter on the strainer grid. There is mostly dirt and dead bugs at the bottom right now, When the bug picks it up it the grid just gets clogged. I dont know if there is a way to leave off the grid since its screwed on by a nut for that application. Could i just make the holes bigger on the grid?
I see that this is an older comment /question. I have the same problem. I’ve tried both intex vacuums(garden hose and suction into a small net bag), as well as a standard suction vac and a ladybug vac both going right into the strainer grid. The strainer grid is an engineering mistake. It prevents you from genuinely cleaning the pool. Have you had any success or progress on this?
 
Last edited by a moderator:

Vinnyd0810

Member
May 29, 2019
9
Middletown nj
I have tried many ways of vacuuming this pool. The suction inlet is a strainer. This hampers any efforts to vacuuming debris with any success or consistency. You are at the mercy of how quickly the strainer grid gets clogged. Once it does, you have to try and clear that strainer and hope to get the debris out of the pool and not back into the pool. The strainer grid seems to be a built in part of the inlet assembly. It is not an optional piece that can be bypassed. I am not a fan of the 2 proprietary methods of vacuuming offered by intex(venturi and suction into a small net bag). Does anyone have a good solution?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Welcome to TFP! :wave: All I can offer are some previous discussions (below) of others who tried various methods. Maybe one of these will be helpful to you.