Intellitouch indoor control panel not responding control actions

blairsooley

Well-known member
Oct 29, 2016
56
Spring/TX
Hi all, my indoor Intellitouch panel responds to some button presses but not others. I am getting the error retrieving data message when trying to recall data from the central control board and the control actions (turn on spa, lights, etc) don't do anything other than beep when the buttons are pressed.

Note that this problem existed when I purchased my house so I purchased the Screenlogic wireless kit, which upgraded the firmware on the main Intellitouch automation board and all of a sudden the indoor panel started to work correctly. However, after 6 months or so it stopped working again. I've been lazy but getting back to it again.

Thoughts? Thanks
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
19,178
Bedford, TX
Blair,

ScreenLogic can't update the F/W on the IntelliTouch system.. It can't be done without special equipment.

Not sure why your indoor remote started working...

Let's see if Tom has any feedback, as he knows all about the IntelliTouch and Pentair remotes.. Calling @ogdento

Thanks,

Jim R.
 

ogdento

Bronze Supporter
Mar 30, 2015
572
Chico, CA
Hey Folks,
Can the screenlogic and your VSF pump still talk to the outdoor board (e.g. is it just the indoor panel that has a problem)?

I can't tell whether you have an i5 (with a single comm port plug) or an i7/i9 (two comm port plugs)... but, if installing the screenlogic "fixed" the indoor unit, I'd guess that the indoor unit wasn't actually broken and the mere act of adding extra wires to the comm port terminal block for screenlogic did the trick (there was likely some dirt/grit/loose connection on the comm port connector?).

That isn't to say you don't have an actual hardware problem now, but I'd start on the "bad/loose connection" path.
1. Shut the power off to everything and inspect the comm port pins/terminal block for corrosion and see whether there's a good solid connection. Using a multimeter to check continuity would be useful.
2. if #1 checks out, try connecting only your indoor panel to the outdoor board with a short "known good" length of cable
3. if #2 fails then there could be a problem with your indoor panel... if you're able to measure the dc current draw and you get much more than 180mA with backlight and leds at 100%, then it's probably got a blown comm port
 

blairsooley

Well-known member
Oct 29, 2016
56
Spring/TX
Thanks for the responses and for the clarification on the firmware update. My indoor board started working (for awhile) immediately after I installed the Screenlogic and ran the firmware loader software that goes with it, then restarted the i7. I was under the impression the loader software was updating the i7 but I must have been the board for Screenlogic that was being updated.

Based on this, the problem does indeed sound physical (dirt, bad wire, port). I'll clear everything up and check continuity on the pins and try switching comports with the screen logic to see if the problem follows the board.

Appreciate the thoughts,
Blair
 
  • Like
Reactions: Jimrahbe

blairsooley

Well-known member
Oct 29, 2016
56
Spring/TX
Details of testing. I have 3 items connected to 2 serial ports.

Comport 1 - Screeenlogic and VSF pump. Both working fine. Being a controls guy, this is not preferable, however, it seems to work as only one device talks at a time.
Comport 2 - Indoor control panel Pentair part number 520164, Version either 1019, 1619 or 1819, second number hard to read. Date 5/29/2003.

Tested continuity of all port wires from i7 connector to back of 520164. Call connections fine. Connectors cleaned. Switched ports on the i7. The screenlogic and VSF work on both. The 520164 works on neither. Continues to give 'Error Retrieving Date' message when Program button is selected, however, does continue to update with correct status of outdoor temp and pool temp, running status of equipment, etc.

All signs point to either a bad port on the indoor board or there is a firmware mismatch between the indoor and outdoor boards. Is the latter situation plausible, that either the 520164 or i7 have incompatible firmware versions?

i7 firmware is 1.16 (per the Screenlogic program)
I tried the process in the Intellitouch manual to read the 520164 firmware (press buttons 2 and 4 simultaneously but it gives me the Error Retrieving Data note. Is there a way to check the firmware on the 520164 only?
 
Last edited:

ogdento

Bronze Supporter
Mar 30, 2015
572
Chico, CA
hey blair,
i agree... if the screenlogic and pump are working then your outdoor board's comm port is fine, and since the indoor controller cabling checks out then the indoor controller's port is likely bad. you can pm me if you want to get it repaired or want to diy it.

fyi - the two comm ports on the i7 are connected together so it doesn't matter whether you put all the wires into one terminal block or use both terminal blocks.

i've never seen a mismatch in firmware cause a communication issue - that's not to say it can't happen. the 2003 date on the indoor unit predates the 1.160 firmware by many years... I wonder if they updated or replaced your outdoor board when the VSF was installed (it wasn't supported in older firmware) but didn't do the indoor?

You should still be able to see the firmware on the indoor... after you get the "error retrieving data", you should still go to the software version screen - it won't show the outdoor unit's version (uoc) but it should show the indoor.
 

blairsooley

Well-known member
Oct 29, 2016
56
Spring/TX
Thanks Ogdento. I was able to find the indoor panel firmware version is 1.023. The outdoor unit must have been updated at some point before 5 years ago as theat's when I bought the house and I installed the VSF 2 years ago. The ScreenLogic is able to control the VSF though it does seem a bit wacky at times. Is there a newer version of firmware for the outdoor unit that is better suited to the VSF?

All that said, it sounds like I need to replace the comport so I'll PM you on that. Typically I'd DIY but I may not have the tools nor patience depending on the soldering required.
 

ogdento

Bronze Supporter
Mar 30, 2015
572
Chico, CA
Ahh ok... so yeah they never updated the indoor. The latest version of the firmware is 1.190 and the release notes say there are VSF fixes, although I don't know what they are - I only have a VS pump. 1.190 also lets you set your date/time year past 2020 from the indoor unit... not allowing that in prior versions was a little oversight on Pentair's part I think ;) Actually, I'd be curious to know if your screenlogic can set a 2021 or greater year... I'm hoping it's only indoor units with less than 1.190 that can't.