Intellitouch clock frozen after battery replacement

#1
Original problem was that whenever I lost power to the intellitouch the clock would reset to 12:00am. I replaced the L-ion battery on the intellitouch main board (it was 0.0 Vdc). Now the clock will not keep time. All it does is hold the time you enter.

Is there a reset sequence I must perform to restart the clock? (I have tried pressing reset).

Everything else seems to work.
 

CountryBumkin

Bronze Supporter
Jan 9, 2017
124
Orlando/FL
#2
Did you replace with same battery (same make and model)? What make/model battery comes installed?

I have the i7 and I don't recall seeing a battery in it (or reading about it in the manual).

Is this like a watch or computer motherboard battery? If so, it might be possible to install upside down. Double check.

I was just Googling on this but couldn't come up with anything.
 

pabeader

LifeTime Supporter
TFP Guide
May 14, 2015
4,349
Cartersville Ga
#3
From the manual I could find, it looks like you are supposed to set the clock and then press the EXIT button when you are done. Can you post a pic of your panel?
 
#4
Thanks for the replies. The battery is a CR2032. It is a run-of-the-mil 3V coin battery. pool.jpg
I also looked at all the information I could find on-line about this system and came up zilch on the battery. Whenever I have a real-time clock problem I think to myself "battery". It was indeed dead so I replaced it. New battery is in the same direction as the one I pulled out, matched the board (attached photo), and reads per the polarity marked on the CCA.

I did set the clock per the manual and per your suggestion (press 'set->exit')... no joy..

Will the attached pic do?
 

pabeader

LifeTime Supporter
TFP Guide
May 14, 2015
4,349
Cartersville Ga
#5
Sorry, I was looking for a pic of the panel, just to be sure I was reading the correct one.


Hmm... You got me on this one. I'll put more thought into and see what comes up. In the meantime maybe someone else will have the knowledge.
 
#8
Problem Solved.

After a series of desperate button-pushing and resetting I stumbled across the solution.
After you replace the battery you must reset the 'House Address', even though I don't have any expansion modules, as spelled out on page 15 of the Intellitouch Installation Manual. As an aside, I might have inadvertently reset back to the factory default settings prior to this action (either by the battery replacement or by all the buttonology I performed).

Thanks for everyones help.