IntelliChlor ic40 cell light wont turn on

georgewever

Member
Jul 9, 2011
8
Joplin, MO
I have a Intellitouch panel with an IntelliChlor salt generator on my pool. This year for some reason the cell light remains off and where the sanitizer output lights are (20%-40%-60%-80%100%) they do not turn on either. The rest of the lights turn on normal. I did clean the cell this offseason and not sure what would cause this. Anyone have info on this issue?

Thank you,
George Wever
 

patrick3229

LifeTime Supporter
In The Industry
Feb 2, 2012
271
Hi George,

How old is your salt cell? The cells have a life span of 2-5 years based on if you run the cell all year round or just for the swim season. Also could you post a picture of your cell so we can see the exact diagnostic lights that are lit.
 

FLPoolDIY

Well-known member
Aug 29, 2016
102
Land O Lakes, FL
I had the same issue with mine. Unfortunately, the only fix is to replace the unit. The down side to the intelliChlor units is lack of field replacement parts. The only part that is replaceable in field is the flow switch.

I lucked out and had one month of warranty remaining when mine failed.
 

georgewever

Member
Jul 9, 2011
8
Joplin, MO
Thanks for all the responses, The unit is about 7 years old and i only run it in summer as i have to winterize my pool every year with the weather in Missouri. I do belive the cell has gone bad just wasnt sure if there was a way to fix it or if it had to be replaced.

GetAttachmentThumbnail.jpg
Should have mentioned the low light was flashing at the time and appears off but wasnt. The Cell light and bottom light showing the % don't turn on at all this year!
 
Last edited:

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
13,083
Bedford, TX
George,

Have you done this test???

Pressing and holding the “More” button launches the System Status Mode. When the lights finish scrolling, the percent lights indicate hours of usage in 1,000s. For example, if the 40% light lights, that indicates 4,000 hours.

Jim R.