Intellichlor 'clean cell' question

barryburkholder

New member
Jun 27, 2010
2
I have an IC40, v1.8. I am in PA so pool runs less than 1400 hours per year. (typically have the generator set at 60% to 80% depending on water temp and it keeps up all season long).
I am getting 'clean cell' message (Cell light flashing) on the cell and through the intellitouch control. The cell looks clean-no calcium build up. I removed and acid cleaned and am still getting the clean cell warning. I believe the generator will not turn the cell on to even try to make chlorine when it thinks it is dirty. Is this an indication my cell is malfunctioning? All other lights (pwr, life, flow) are green. Is there a way to over ride or re-set, much like when it reads low salt but the salt level is good and it can be recalibrated? Pool water is perfectly balanced (pH 7.6, ta 90, calc. hardness 250). Salt level 3200ppm. Cyanaric adic 80ppm. Current water temp, 88 f.
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
Welcome to TFP!

There are two things which cause the cell light to flash green, a dirty cell and water temperature below 60 degrees.

In addition to acid cleaning you can also try a detergent cleaning (soak in a mixture of automatic dishwasher detergent and water, 1 cup of detergent for every five gallons of water, and then rinse off throughly).
 

barryburkholder

New member
Jun 27, 2010
2
I appreciate your reply..what is confusing be is that the cell is as clean as new. In your experience, could there be a non visible coating on it?
 

bk406

Well-known member
Dec 3, 2009
2,690
Central Massachusetts
This is actually a bug in the 1.8 version. Others have had similar issues. First thing i would do is power the cell down. Either turn off the power supply, or the Easytouch box if you have one, then unplug the cell. Then, plug it back in, and power it up. This may reset it. If it doesnt, call Pentair and tell them whats going on. I know they will have heard this before.
 

Pool Clown

In The Industry
Sep 5, 2008
1,882
Silicon Valley, CA
You need to have this cell warranty-ed, ver 1.8 has problems (as noted above). Look at your manual, this needs to be your original manual as these manuals read that you have a three year warranty on the cell. Newer manuals wont have that wording (only a 1 year in current manuals). Unless you got a new Pentair pump and filter at the same time, then your warr is 3 years on all three.

Good luck
 

Other Threads of Interest