Intellicenter app/web - freezes, changes don't hold, etc.

Poolmama!

Silver Supporter
Feb 20, 2019
81
Dallas, Tx
Am I the only one having constant problems with the Intellicenter iPhone app and web log in via Mac?

The app isn't saving any pump speed changes. If the pump is set for an rpm of say 2,000 and I wanted to change it temporarily to 2,200, I could just tap the + button twice and voila. Now it might change it, but then it reverts back to 2,000. And since it was installed, it's constantly freezing or logging me out. I've tried deleting the app and reinstalling it (and made sure it was updated to the current version).

The web log in saves my pump speed changes, but then it locks up as well and I have to force quit it and log in again.

Anyone else? I haven't tried contacting Pentair yet...thought I'd check to see if anyone else has had the problem and figured out a fix.
 
Last edited:

MyAZPool

Gold Supporter
Jul 3, 2018
970
Arizona
Recommmend that OP contact Pentair Tech Support, as none of those issues are normal and I have not experienced any of the same.

I would be curious as to what firmware release that the OP is running. The current publicly released firmware update is v1.023. However the IntelliCenter ships with v1.019. So if OP has not performed an over-the-air (OTA) update, then it's possible that may be where the problem lies.

However, there are some firmware beta releases (v1.024 through v1.036) that Pentair may choose to provide to the OP that may or may not fix those issues. I have reviewed the beta release notes and there are no mentions specifically regarding these issues but you never know.

Both, my iOS app and desktop Web-Client are responsive to any changes that I make. I am always experimenting (playing) around with different configs and settings and any changes that I make within either platform, properly save in both platforms and do not revert back to previous settings.

The only sort of goofy thing that I have experienced along these lines, is when I make modifications within CIRCUIT GROUPS in the Web-Client and save, I then have to exit that screen (back to HOME) and navigate back to the SETTINGS > SYSTEM CONFIGURATION > CIRCUITS > CIRCUIT GROUPS, in order to see the changes made.

EDIT. When I change a pump flow or speed. It immediately takes effect and does NOT change.

All of my pump flows/speeds are tied to FEATURE CIRCUITS. What I mean by that is that I first create a FEATURE CIRCUIT in SETTINGS > CIRCUITS called let's say 1500RPM and then click SAVE. Then I navigate to the SETTINGS > PUMPS page and select that particular FEATURE CIRCUIT (1500RPM) in the CIRCUITS pull-down menu and then i click the RPM radio button and then I set the speed to 1500.

I can then embed that FEATURE CIRCUIT within whatever CIRCUIT GROUP (macro) that I prefer.

That is how I do it. The IntelliCenter Control System User’s Guide is not nearly as detailed but alluds to the same (Speed Circuits: Assign the speeds to the circuits you wish to use).

If someone chooses to do it some other way, that's fine, but the method that I have oulined above is what works for me and I am experiencing zero issues with pump speeds/flows.

NOTE: The procedures that I have outlined above are while using the Web-Client (it is the easiest method of IntelliCenter configuration setup and modifications). The procedures while using the control panel or the phone/tablet app are just slightly different but will accomplish the same result.

r.
 
Last edited:

mrweber

Active member
Jun 7, 2015
32
Norco, CA
I have experienced this via the iOS app when connected to my system as a "Remote System". I almost always use the remote connection even when on my local wifi due to spotty wifi out by the pool. The intellicenter itself is hardwired. I also have my pump speeds as feature circuits like @MyAZPool describes, but sometimes I will speed up or slow down those speeds temporarily via the "Pumps" screen in the app. This is where I notice the lag and the speed resets described by @Poolmama!. I will try using a local connection, but I believe the issue is with poor connectivity with the intellicenter via spotty wifi and the remote connection. Just enabling the feature circuit on/off works perfectly fine. I don't do this often enough to waste my time contacting Pentair tech support who will for sure be clueless.
 

MyAZPool

Gold Supporter
Jul 3, 2018
970
Arizona
So I thought I would do some further testing on this issue just to see for myself, what might be going on. Here is what I found using both of the connection options in the iOS app.

1. Using the iOS App REMOTE CONNECTION option (connecting through the Pentair servers): I could not replicate any issues with the pump speed not changing or indicating the same on the mobile app. When I stood at my equipment pad and made speed changes on the mobile app using the “REMOTE CONNECTION”, I saw the speed indication change in real time on the touch screen and I also confirmed same by hearing the speed change at the pump. I also tested this mobile app remote connection on my iPhone while looking at the Web-Client. Same thing. The speed changed in the Pumps Page in real-time.

2. Using the iOS App LOCAL CONNECTION option (connecting locally via intranet) to a "local pool" without using the Pentair servers: When I made an adjustment to pump speed in the iOS app, I found that Poolmama! and mrweber ARE correct. It does not change the speed “indication” in real-time on the app. But it does actually make the speed change at the control panel/pump and indicates the same change on the Web-Client.

However, it should be noted that if making the speed change in the app using the local connection, if you close the app and log back in and navigate back to the Pumps page, the correct speed change WILL be indicated in the mobile app.

I would agree that this is a bit goofy but I really can't think of a good reason to perform this function from a mobile app. Programming or configuring IntelliCenter settings on a mobile platform seems like a whole lot of work and I think that one would be better served by just sitting down at their computer and using the desktop Web-Client to program or configure their system. This is why I recommend the use of the desktop Web-Client or if nothing else, at least the Control Panel Touch Screen to set up/program user's IntelliCenter configurations. I have tested programming configurations using all three platforms and the desktop Web-Client is by far the easiest and most user-friendly.

I would recommend that if a user insists on using their mobile app to configure their IntelliCenter settings and they encounter this issue, they should report it to Pentair Tech Support so that the software team there, can address this issue and consequently release an update to the mobile apps that will correct the problem.


NOTE: The following conditions must be met when attempting to use the “local” connectivity feature (Connect to a local pool) in the iOS app (I have no idea if this is the same with the Android app, but I can only assume that it is).

1. Security must be disabled at the IntelliCenter Control Panel.​

2. The IntelliCenter Control Panel must have LAN connectivity (connected to the user’s network either via Wi-Fi or a wired ether connection).​
3. The user’s mobile device must have connectivity to thier LAN via a user’s local Wi-Fi signal. Please note that there is one exception to this condition as noted below.​
If the user has the ability to connect to their network from a cellular connection using a VPN tunnel, a user CAN connect either “locally” or "Remotely" using cellular service without the need for a Wi-Fi connection for their mobile device.​
I have tested this feature using both the local and the remote options and it works great without any connectivity issues to my control panel and without any latency issues using LTE. In other words, if mobile device Wi-Fi connectivity is an issue, one can download and configure a VPN app and connect to their IntelliCenter using a cellular connection (3G, LTE etc.) Just remember, this connection may count against your cellular data plan if applicable. :)
 
Last edited:
  • Like
Reactions: mrweber