IntelliBrite light Intermittent issue

TonyR68

Bronze Supporter
Apr 22, 2021
60
Dunwoody, GA
Pool Size
24000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Hi All,

I’ve had an issue with my IntelliBrite 5G Color LED pool light 120v for a while. Most of the time when I switch on the pool lights they come on fine and are in sync. However, sometimes when they come on, one light flashes on briefly, goes off and comes back on a few seconds later in either sunset or romance mode (I’m not sure which one). If I then change color (via App or OCP) both lights will come back on synchronized to whatever new color/mode I choose. The issue is intermittent typically happening every few days or weeks. However, over this winter, with the lights coming on every evening, it did not happen for months, but last night it started happening again.

I’ve logged the issue with Pentair and twice they sent me a replacement Light Engine for the faulty light. The issue is only with one light. I did not install the second replacement light engine as the water was too cold and decided to wait until the summer.

Setup: 120v supply -> IC Relay -> GFCI -> J-Box -> Lights. Both lights share the same GFCI, connecting to supply in the J-Box.

I’ve included a before picture and an after picture. Here is also a short video showing what happens. If you go frame by frame, you will see the red coming on briefly (~1 frame) before going off.

Any guidance would be much appreciated. I would like to do something before just installing another light engine.

Thanks




1678542729353.png

1678542768127.png
 
Last edited:

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
41,245
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Not much you can do except keep on making warranty claims with Pentair.

I would wait until your pool water warms up and see if your light still does not work correctly. It may be the electronics does not like the cold.

I am glad to hear that Pentair sends out warranty replacement lights. You would think Pentair will come out with a new model with improved reliability but they have not. They must have done a huge manufacturing run of lights and still have many warehoused to sell before they come out with an improved model.
 

generessler

Gold Supporter
Silver Supporter
Dec 13, 2020
407
Chapel Hill, North Carolina
Pool Size
19000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
I have had various weirdness with LED devices that turned out due to a simple thing: a badly done wire nut connection. Finally figured it out upon hearing a crackling sound from the control box. Apparently the arcing was driving the LEDs and their control circuits crazy. Since fixing, no more odd switching on and off and early device death. This was not pool lights, but rather landscape lighting, but maybe the root cause is similar.
 

TonyR68

Bronze Supporter
Apr 22, 2021
60
Dunwoody, GA
Pool Size
24000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Thanks @ajw22 and @generessler for your feedback.

I did listen for any crackling but did not hear any. I decided to just check/tighten the wire nuts in the junction box (where the 2 pool lights connect to the pool GFCI). To my surprise, I noticed a lot of rust around just the conduit going to the light I’ve had issues with (picture attached). The J-Box is about 18” above the pool waterline. Not sure what would cause the rust or if it is related to my issue.

Any guidance would be much appreciated.

Thanks,

Tony
 

Attachments

  • E1CBB64A-506D-430B-B844-DED8E2ED39A5.jpeg
    E1CBB64A-506D-430B-B844-DED8E2ED39A5.jpeg
    318.6 KB · Views: 7

generessler

Gold Supporter
Silver Supporter
Dec 13, 2020
407
Chapel Hill, North Carolina
Pool Size
19000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Jandy Aquapure 1400
ten for any crackling but did not hear any. I decided to just check/tighten the wire nuts in the junction box (where the 2 pool lights connect to the pool GFCI). To my surprise, I noticed a lot of rust around just the conduit going to the light I’ve had issues with (picture attached). The J-Box is about 18” above the pool waterline. Not sure what would cause the rust or if it is related to my issue.

Any guidance would be much appreciated.
I'm not an electrician, but this looks fairly normal and shouldn't be a problem. It's likely the box isn't perfectly weather tight. So wind-blown rain can seep in and pool at the bottom. That's what this looks like. If there are any weather seals on the box, you could replace them.