Included 1000gph pump fails to start

chicagonyc

Member
Jun 14, 2020
17
Houston, TX
The included 1000gph pump that came with my Bestway AGP used to work just fine. But today the pump fails to start. I normally click the "reset" button on the GFCI switch which starts it right up. Now, I tried clicking "reset" (and "test") like 50 times, and it started up only once in those attempts. It stopped working after about 15 seconds or so. The outlet does work because I tested something else on it. When I click "reset" the red indicator light does not stay on, btw.

It seems like an electrical problem of some sort. Is there any hope of saving the pump? I tried calling customer support (I purchased the pool about 3 months back) but it seems they've gone all virtual and there's no one to talk to.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
I tried calling customer support (I purchased the pool about 3 months back) but it seems they've gone all virtual and there's no one to talk to.
Isn't that convenient. :brickwall: Unfortunately you're not the first person to mention how difficult it is to contact a customer support office for help. I'm afraid that may be your best option though. Those small Bestway, Intex, and Coleman pumps are all one-piece, self-obtained products. Not much you can do with them really if it's not something extremely obvious. Maybe just look inside to make sure something didn't get clogged or jammed-up in the pump intake, but if not, that's about it. With such a new product that should still be under warranty, you may just have to keep trying.
 

chicagonyc

Member
Jun 14, 2020
17
Houston, TX
After trying maybe for several dozens of attempts, the pool pump finally started up. Not gonna turn it off for a while :)

Some youtube searching yields some suggestions of taking apart the GFCI box and cleaning corrosion. May try that if it doesn't work again.
 

Blacklisted

Well-known member
Sep 10, 2013
229
El Cajon CA
By chance is the outlet you are plugging the pump into already GFCI protected? If so you can remove the GFCI plug from the pump and put a normal plug on the cord. It could be a double GFCI is causing it to trip. Even if there is no GFCI outlet you can put a standard plug on to test if it's the GFCI being faulty. It that works you could just go to the closest home center and put a GFCI outlet in and run the standard plug on the pump. Probably cheaper than replacing the one on the pump.
And I would highly recommend upgrading your current pump and filter to a sand filter. You will be cleaning the cartridge filter every other day it seemed like. The sand filters are great and easy maintenance.
 
  • Like
Reactions: sammckin

TimandCeri

Bronze Supporter
May 13, 2020
41
Vancouver, Washington
Mine died last week as well. Did you register it with them? If you did you have an account created. You can email them for a callback but if you registered it you should be able to open a claim. Wich, I would do it while it's still under warranty ASAP. Don't tell them you are going to try to fix it. I don't have to return anything, so if you get it working you should be good! The pump should be warranted for a year. Mine is under warranty, my replacement was approved, but it's out of stock. :rolleyes: I just snapped a picture of it and told them it would not power on.