iChlor 30 to be controlled by intelliconnect.

moore887

Gold Supporter
Silver Supporter
Bronze Supporter
In The Industry
Aug 14, 2018
364
CAPE CORAL
Hi,

I have taken over a pool and i have logged into the pentair app and am able to see all the equipment except the salt cell.

Its wired correctly by the builder acdording to my research. When i hit the + on the app to add new rquipment an intellichlor is not an option
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,889
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
There is no such thing as an Intellichlor 30. There is an iChlor 30 which I do not believe is controlled by Intelliconnect automation.
 

moore887

Gold Supporter
Silver Supporter
Bronze Supporter
In The Industry
Aug 14, 2018
364
CAPE CORAL
Yup. Its an ichlor although Jim did refer in an older thread about having a two wire connection from the ichlor power box (green and yellow) going to the intellichlor. That wire is in place.

I honestly don't see any advantage of having the swg output app controlled unless the cell was in a difficult to reach location.

My main concern is that there are no lights at all on the cell. Breaker panel is good and everything is less than six months old. I think the customer may have to call the pool builder on this one.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,889
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
My main concern is that there are no lights at all on the cell.
Then it is not wired correctly.
The iChlor can be controlled via RS485 by the ET, Intellitouch, Suntouch, but no reference to Intelliconnect. It can also be direct connected to an Intelliflo pump and the iChlor will be turned on off via the pump system.
 

moore887

Gold Supporter
Silver Supporter
Bronze Supporter
In The Industry
Aug 14, 2018
364
CAPE CORAL
OK, I am not sure if I am making progress but what you say is absolutely correct. The Intelliflo can be connected to the ichlor and that can command the swg to turn on and off. The RS485 port on the pump is connected to the intelliconnect and I can control the pump perfectly. There is another wire coming from the intelliconnect and going to the ichlor power center (two wires). So I'm thinking is this just come kind of passthrough from the pump, and if it is, how can I tell the pump to turn on the salt cell. I'm guessing that it may just be something as simple as a minimum speed threshold but it could be something like a program preset option so you can chose not to have the SWG turned on in the evening. I will keep reading this manual
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,044
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Check how the pump is defeined and setup on the IntelliConnect.

The IntelliConnect manual says it can control the iChlor through the RS-485. See https://www.pentair.com/content/dam...elliconnect/intelliconnect-manual-english.pdf

Page 4:

Wiring a Salt Chlorine Generator (SCG)
IMPORTANT!: When a salt chlorine generator is connected
to IntelliConnect, a single speed pump designated as "Filter
Pump" or IntelliFlo pump MUST be connected.

A salt chlorine generator should be wired to one side of the
RS-485 Terminal (Figure 5) according to the markings on
the control board.

When an IntelliChlor or iChlor SCG is wired to
IntelliConnect via an RS-485 cable, a power connection
to the load side of the pump relay is not required. Digital
commands sent from the IntelliConnect to the SCG will not
allow chlorine production when there is low/no power to the
filter pump relay or when the IntelliFlo is not running.

Only wire the RS-485 cable's YELLOW and GREEN
conductors to the RS-485 Terminal.
Cut off and terminate
unused conductors according to local and national electrical
codes.

Note: After IntelliConnect has operated in Service Mode
for 3 minutes, IntelliConnect will maintain chlorine output
adjustments made at the SCG when placed back into Auto
Mode.

Page 9:

IntelliChlor/iChlor generators, IntelliFlo pumps and heaters should receive power directly from the breaker (to receive constant power) and should not be wired through Relay 1 or Relay 2.
 
  • Like
Reactions: mknauss

moore887

Gold Supporter
Silver Supporter
Bronze Supporter
In The Industry
Aug 14, 2018
364
CAPE CORAL
Thanks Allen,

A lot to take on board there. There are only two wires (yellow and green) going to the ichlor controller. Customer says at one stage, the cell was lighting up. That's all he knows.

I think that intelliflo VSP is wired off one of the relay buttons and not directly off the breaker. I need to check that, because I did turn off the breaker for the intelliconnect but I can't remember if the pump kept running. Also on the pump, I changed something on it in the menu to say external controller. I can also control the speeds and timers of the pump in the pentair home app.

I didn't run the system in service mode for any length of time. It is interesting that if I was to make an adjustment to the swg while it was in service mode that it takes 3 minutes for that setting to be picked up in auto. I used to run into this problem a lot with a jandy system until I got my hands on the remote control.

Manual also says Note: In Auto Mode, if a booster pump or other flowdependent equipment is connected to either relay then the filter pump will be activated for 2 minutes before the relay activates. I just noted that the swg is not connected to either relay so that doesn't really matter.

intelliconnect.jpgScreenshot_20211204-153852_Pentair Home.jpgScreenshot_20211204-153907_Pentair Home.jpg
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,044
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
There are only two wires (yellow and green) going to the ichlor controller. Customer says at one stage, the cell was lighting up. That's all he knows.

To be clear - the iChlor cell has a cable that connects to the Power Center. The Power Center connects to a 120V AC CB and the green/yellow RS-485 cable to the IntelliConnect.

Have you confirmed the iChlor Power Center has AC power? If you open up the Power Center box there is a green LED on the board that should be lit.

I think that intelliflo VSP is wired off one of the relay buttons and not directly off the breaker. I need to check that, because I did turn off the breaker for the intelliconnect but I can't remember if the pump kept running. Also on the pump, I changed something on it in the menu to say external controller. I can also control the speeds and timers of the pump in the pentair home app.

It looks like the IntelliFlo VS pump is connected to Relay 1 based on what is written on the IntelliConnect which is incorrect.

The black plastic on the lower right held on with one screw needs to be removed to see the relay connections.

I don't have the IntelliConnect or the Pentair app and can't explain why no SWGs show in adding a device. I would call...

Customer Service and Technical Support, USA
(8 A.M. to 4:30 P.M. — Eastern/Pacific Times)
Phone: (800) 831-7133
 

moore887

Gold Supporter
Silver Supporter
Bronze Supporter
In The Industry
Aug 14, 2018
364
CAPE CORAL
Got it! I won't know for sure until I go back out there tomorrow and see if it's lighting up. (I should get some salt in, I read at 3050 (spintouch) although my previous read on Thursday was 2700. The trick was to go into the intellicenter and add the salt cell from in there. I can now raise and lower the level. However, there doesn't seem to be a reading on the temperature side.
Screenshot_20211204-183452_Pentair Home.jpg
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread