IC20 Red Flow Light

McLovitz

Bronze Supporter
Aug 26, 2019
87
Livingston, NJ
I saw a few old threads on the Intellichlor flow light staying red and so I apologize for starting a new one. In short, we just had the pool opened (we use a company to open and close the pool and I do the servicing in season) and the flow switch on our IC-20 is red though there is plenty of flow. I tried turning the pump speed up to 3200 RPM and it makes no difference. We are a few months out of warranty on the IC-20 (opening our pool for the third season) and I contacted the pool company that had opened the pool for us. He suggested cleaning the filter, so I did, and no luck. Then he suggested the flow sensor may be an issue and so I ordered a new one on Amazon and installed it tonight. Still red light. At this point, any suggestions anyone has on what I do next before giving up and buying a new salt cell? Really frustrating to be doing this a mere 2 seasons after installing the pool.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,879
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Twist the red and black wires going INTO the cell together. Let us know if that turns the flow light green.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,879
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Means the cell is fine. The flow switch is the issue. Check to be sure it is properly installed. And that you have sufficient water flow through the cell.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,879
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Bad idea. What happens when you turn the pump off, does the cell power completely turn off?
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,879
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I am not conversant in using a four wire old flow switch with the new three wire IC. The black wire is common, so your picture assumes the green and blue are the common. I have never seen a flow switch with a blue wire.

Be sure the connections are secure. Tiny wires so can be an issue to get a good connection.
 
  • Like
Reactions: McLovitz

Enjoying this content?

Support TFP with a donation.

Give Support

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,879
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Something is not wired correctly or installed correctly. Rarely do the flow sensors fail on the flow side of the equation. The thermistor in them fails often, but not the flow switch.
 
  • Like
Reactions: McLovitz

McLovitz

Bronze Supporter
Aug 26, 2019
87
Livingston, NJ
Well, it's fixed and I'm livid. After coming home from work and playing with thee wires more, I took the cell off to inspect it. When I went to screw the cell back in to the fitting, it hit me. There was nothing wrong with the cell or the flow switch. The pool guy who opened us up installed it backwards. I'm so dumb.
 
  • Like
Reactions: Jimrahbe
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread