Hot tub shows "FLO" and won't heat!

FutureSC

New member
Apr 14, 2020
1
Seattle, WA
The other night I was in the hot tub and I noticed the water was getting colder. I looked at the control panel and it said “FLO.” It wouldn’t allow me to adjust the temperature. It has been over a week now and its still not working. I have tried:
  • Turned off circuit breaker, removed filters, turned it back on
  • Left circuit breaker off for several days, then turned it back on.
As soon as I turn it back on it immediately shows “FLO.”

The hot tub was already at the house when I moved in. It says it is a Mountain Springs Spa Everest from June 2001. I've attached some photos.

Anyone have any ideas? I hate to have to spend a ton of money to repair or replace it. Thanks.
 

Attachments

Ian196499

Gold Supporter
Silver Supporter
Aug 12, 2018
88
England
Not sure it is the same issue but on my heat-pump when the control says “FLO” it’s because the pump is not switched on and so no water is getting to the heat-pump. It then switches off the heating so that it doesn’t overheat.
have you checked the pump is running?
 

Bama Rambler

Mod Squad
TFP Expert
Bronze Supporter
LifeTime Supporter
Jun 22, 2009
24,064
SouthWest Alabama
Sounds like the flow switch isn't seeing any flow.
You can make sure that there's flow through the heater and if there is you can temporarily jump out the flow switch to see if that's the problem or if it's the board.

WARNING: turn off all power to the spa!