help with Aqua Tech T-Cell 15

bowl3001999

Member
May 28, 2017
7
Middletown OH
Hi, this probably sounds like a dumb question, but trying to see if my cell is bad and also I think the circuit board may be bad. Just opened my pool on 5/16 and shocked it with a case. At that time, my cell had the salt at 3,000 (I know, I shouldn't trust it). Test 5/20/20, water was around 50 degrees:

PH: 6.5
ALK: 66
SALT: 1900
Free Chlorine: 0
Total Chlorine: 0
CYA: 0
Hardness: 83

Put in Alk up and PH up and one bag of salt (should have put three but waited on the other two). Turned heater on in the evening. Next morning, pool was much clearer and thought all was good. Vacuumed some more and it took about two days to get water up to 82 degrees.

Tested again on 5/22/20:

PH: 8
ALK: 126
SALT: 1654
Free Chlorine: 0
Total Chlorine: 0
CYA: 0
Hardness: 92

Added 2 other bags of salt. Also added conditioner. So, my cell was still reading 3,000 but all the other readings were correct. However, no power light or light where it shows generating.

On 5/23/20 added a case of shock and also tested salt. I bought sticks (to test salt), first time, but it read around 4,000 (6.2 on chart). The water is still not really clear, but I think it will be by tomorrow.

My Tcell readings 5/23/20, late afternoon:
Average Salt reading: 0
Temperature: 82
Cell Voltage: 17.0
Cell Amperage: 0
Output: 55
ISR: 0

Hope all this helps, you would think I would understand all this after having a pool for 10 years. I can call Hayward on Tuesday and get help with the cell, but shouldn't the power light be on? I tried to calibrate it, but it would never click like it's supposed to. Then, yesterday after many tries, it did click and now the salt is reading 0.

Thanks for any input/help/feedback.

Wendy