Help! cloudy pool

TammyGriffin

Well-known member
Apr 23, 2018
273
Hephzibah Ga
Pool was green. Now its been cloudy for almost 2 weeks. At my wits end. Don't know what else to do. I've owned this pool for 14 years and never had this problem
 

woodyp

Mod Squad
TFP Expert
LifeTime Supporter
Apr 17, 2010
10,549
East Texas
Welcome to the forum. As much as we'd like to help you, we're gonna need more information. Namely some reliable test results. Please visit Pool School on the home page and consider getting one of our recommended test kits. How are you testing now? How are you chlorinating?
 

TammyGriffin

Well-known member
Apr 23, 2018
273
Hephzibah Ga
Already been doing the slam and water still not getting better. This is my test results from this morning.
Fc 10
Cc. 2.4
Ph. 7.6
Ch 80
Ta. 80
Cya. 30
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
21,344
Laughlin, NV
Great. You have very high CC. Does the pool stink like chlorine? Have you added any thing other than liquid chlorine lately?

Remember to follow the SLAM Process. It means testing several times per day and raising your FC up to your SLAM level of 12 ppm.
 

woodyp

Mod Squad
TFP Expert
LifeTime Supporter
Apr 17, 2010
10,549
East Texas
Are you constantly circulating the water during the SLAM and are you back washing the filter when it hits a 25% pressure rise?
 

woodyp

Mod Squad
TFP Expert
LifeTime Supporter
Apr 17, 2010
10,549
East Texas
The pool does have the strong smell. Used Floc last weekend. Didn't do anything
No more floc for you!...(please)
Have you vacuumed up the floc? If so, hopefully you didn't vacuum to the filter while it was on circulate. It can goo up a filter and is one of the reasons we don't recommend it. Can you still vacuum any up?
 

woodyp

Mod Squad
TFP Expert
LifeTime Supporter
Apr 17, 2010
10,549
East Texas
FC 12 is our recommended Slam level for your CYA of 30. A point or two higher won't kill you.
Ok. You put in floc....nothing dropped out....floc is still in pool and could be most of your cloudy issue. Stay at it.
 

CarolineM

Silver Supporter
Jun 20, 2018
219
Annapolis, MD
If you have been running your pump and filter Floc may have be in your sand filter messing it up. It is like glue, so check your sand filter. I made the dumb mistake of using Floc and had to through my filter cartridge away, it was hard and clogged.