Hello! New Member.

Prilly1904

New member
Aug 25, 2021
1
Andalucía, Spain
I’m a new member to the site.
Having moved to Andalucía in Spain 18 months ago I become the main pool “boy” with responsibility for maintenance and cleaning.
I have a bit of a problem with algae in the pool now as several things have changed recently; the government have set national charging times recently and my husband has said no filtration in expensive hours (most of the day in the week) so I was having to run it at night and/or the weekends. I’ve also had visitors using the pool for the last three weeks and, just to increase the challenge, the selector unit has started to leak to waste when I do use it causing the water levels to drop dramatically despite having the hose running. I use a Dolphin pool cleaner every night (in the cheap rate) to help. I’m now waiting for a pool mechanic to come out on Friday and fix or replace the unit. Once my visitors have gone home I’m going to shock the pool to death (once my filtration function is fixed). Good job I enjoy a challenge.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
33,644
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Welcome to TFP! :wave: Sounds like you have a couple things going on - a bad multi[rt spider gasket (leaking) and algae. For algae we use the SLAM Process. You can go to that sub-forum if you wish. Of course proper testing with a TF-100 or Taylor K-2006C test kit is a must. Let us know if you have any questions.