Hayward super pump user interface not working

Nick1918

Member
May 24, 2018
14
Long Island, New York
Hi,

I have a hayward super pump vs, model sp2600vsp, which I bought 7 or 8 years ago.

Recently the user interface on top has started glitching. It still runs the program I have set before but I can’t change it. The buttons are acting weird and not doing what they should. All is fine for now, except for some convenience, but still an issue.

Is this something that can be repaired? And what type of cost would I be looking at, is it worth it?

Thanks!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
28,469
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Probably a bad keypad. Unfortunately they are not built to be repaired by the average citizen.

 

Nick1918

Member
May 24, 2018
14
Long Island, New York
Thanks, now it’s only running on max speed. So my variable is now a single speed.

Is this something worth bringing in and getting fixed? Or live with single speed until it stops working completely?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
28,469
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Thanks, now it’s only running on max speed. So my variable is now a single speed.

Is this something worth bringing in and getting fixed? Or live with single speed until it stops working completely?

The higher speed is just costing you a bit more in your electricity.
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.