Hayward Omnilogic Upgraded

f30er

Active member
Jan 22, 2022
39
Buford, GA
Here's my prior thread just telling how I got here:

Now:
Ok thanks all. Wound up upgrading to the Hayward Omnilogic system for all in ~2500. Everything is now able to be controlled by my phone and from what I understood about the system, it's also relatively futureproof as my existing pool equipment gets replaced over time.

But there's a problem. I tested my chems yesterday, granted after an extremely rainy day, and my FC was practically 0. Since it was late evening and the pump just turned on, I tried again an hour or so later and it was still 0. When I opened the SWG control panel:
Power light: green
Aqualink RS: Green
No Flow: Red

I saw that the flow sensor is now plugged into the Hayward Omnilogic instead of the SWG. I left it running overnight with the SWG turned up to 70%. This morning, same, minimal FC.

Ideas?
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,817
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You say flow sensor is plugged into the Omnilogic.

Where is the T cell wire connected to? The Omnilogic or your old Aquarite panel?
 

f30er

Active member
Jan 22, 2022
39
Buford, GA
Ok I opened up the Omnilogic, there's no place in there to plug in the cell. I did move the Flow sensor from the Omnilogic back to the SWG which fixed the flow light, but then the Omnilogic kept giving me an error for the flow sensor. Disabled the flow sensor in the settings, but still no Generating light. I dumped in a couple gallons of LC just till I can get the peeps that installed it to come over and check it out.
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,817
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Your OmniLogic board should look like this and the cell should plug into K.

If you don't have this board post a pic of what you have.

Hayward_OnmiLogic_Board_Labeled.png
 

Enjoying this content?

Support TFP with a donation.

Give Support

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
38,817
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
You got an OmniHub.


The Installation Manual is at https://www.hayward-pool.com/assets...ls/OmniHub_InstallationManual_092711_RevD.pdf

Page 21 says:

Optional Aqua Rite Salt Chlorination
The OmniHub can control an Aqua Rite chlorinator and generate chlorine based on the pool's ORP level (using HL-CHEM) or as a percentage of run time, producing small amounts periodically throughout the day. The standard Aqua Rite requires an HLAQRPCB communication board (sold separately) and connects to the OmniHub in the same manner as a Smart Relay. The HLAQR940 bundle (OmniHub + AQR940 Aqua Rite) contains the HLAQRPCB kit which can be used with minor assembly (see instructions included with the bundle).


You need the HLAQRPCB communication board to connect your Aquarite panel to the Omnihub.

Did your installer do that?
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread