Hayward OmniLogic schedule issue

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Running a new pool and having issues with the scheduler on a OmniLogic Pl
I have scheduled 3 different schedules in the OmniLogic. Staring out at 80% for an hour in the morning then decreasing to 60% for 8 hrs then 50% for 4hrs.
Pump turns on and off any the correct time but always turns on at 75%. Schedule shows up on the Hayward app and in the wired controller at the Omni.
Have deleted the schedules and put them back in several times using the app and the hard wired controller.
Every time it’s reverts back to the 75% setting.
36990836-62E5-4ECD-84A8-BA1B9CEE8EAC.png
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
What pump model do you have?
Deleted the schedules, turned Omni off and killed power.
Turned it back on reset the schedules and it appeared to work.
Should be running at 60%.
it ran at 60% for a few minutes . Went back to the app 15 min later and it shows it at 75% again.CC166553-B420-4803-BFFF-F3D666B9592A.jpegCC166553-B420-4803-BFFF-F3D666B9592A.jpeg3FFA8DD6-BA41-4089-8564-F4988DFF4F60.png
 

Attachments

  • 1D44738C-C679-4855-9F96-A55BB646C95E.jpeg
    1D44738C-C679-4855-9F96-A55BB646C95E.jpeg
    494.2 KB · Views: 8

cptkirk

Well-known member
Jul 29, 2018
208
FL Panhandle
I would start with verifying that your pump is configured properly in the controller. I don't have the PL controller, but on my Omnilogic there is a Configuration Wizard on the control panel where the pump parameters are set up. For example, type of pump (which should be variable speed), the minimum and maximum RPM, speed presets for low/medium/high, etc.
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Played with it some more. Whatever the pump is set at in the wired controller is what it runs at despite the schedule having a separate pump speed.
i have 3 different speed set up in 3 different schedules. The pump comes on when the schedule start time says to but despite what you have set as your pump speed it runs at whatever the hard wired controller is set at which is 70 now.
Noticed the lights are the same way.
You can set different color schemes according to a set time in the schedule but it will only display whatever you have chosen in the hard wired controller.

if this is normal why do they let you choose a pump speed in the schedule platform?
 

cptkirk

Well-known member
Jul 29, 2018
208
FL Panhandle
The app is essentially a wireless remote for the control panel. The app communicates with Hayward servers over the internet, which in turn communicates with the control panel, which then communicates to the equipment. The app does not directly communicate with the equipment. Thus, whatever schedules you set up on the app should be reflected in the control panel; and whatever you set up directly on the panel should be reflected in the app shortly thereafter. Have you taken a look at the schedules in the panel to see if they match what the app displays?
 

PoolBrews

Well-known member
Oct 16, 2019
362
The Villages, Florida
When you say "wired controller", are you referring to the controller that is attached to the pump itself? If the pump is wired properly, the display on the pump will be inactive. If the display is live, it's not wired and configured right.

Also, if you have a heater, you can set the min RPM needed for the heater. If that is 75%, when the heater runs, it will ramp the pump to 75%, then back to the scheduled setting when the set temp is reached.
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
The controller is the one wired into the Omni itself.
yes when I change the schedule on the app it reflects the changes properly on the controller . They are the same on both.
When you go into the pump settings in the controller you can set the pump speed . Whatever the pump setting is in there is what the pump runs at regardless of what the schedule setting is.
I currently have the controller set at 70%. You have to have a set speed in the pump settings of the controller to make the pump run.
When the schedule comes up to run at 50% it stays at 70%.
no heater
I can turn the pump down in the app to a different setting and when the next schedule comes up the Omni turns the pump back to the default 70% or what ever is set as pump speed in the controller
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
For now I have it set at 65% form 10a-9p .
That speed keeps the bubblers in the tanning ledge a a good height and the jets in the swim out going.

That seem like enough or to much for a 34500g pool?

my math seems to work. Pump is capable of 130gpm. At half the rpm that’s 65gpm.
34500 gallons /11hrs is 3136
3136/60min=52 g /min

if I run pump slower than 65 the bubblers are to low.
 
Last edited:

cptkirk

Well-known member
Jul 29, 2018
208
FL Panhandle
So the app and the controller agree, which means there is no communications problems between the app and controller. If I'm understanding your problem, whatever speed you have manually set (regardless of whether it is from the app or the controller directly) is the speed the pump runs at when the schedule activates, regardless of the speed the schedule sets. I think you also said you have a similar problem with the lights. Have you checked that the date and time in the controller is set properly?
 
  • Like
Reactions: joboo7777

Enjoying this content?

Support TFP with a donation.

Give Support

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
The pump and lights come on at the correct time per the schedule.
The pump is set to turn on at 10am at 65%.
it turns on at 10am but runs at 75%.
Went out yesterday. Deleted the schedule. Turned the pump down to 65% with the wired controller. Reset the same schedule . Pump ran at 65% until the schedule i set told it to turn off.
Pump came back on this morning but Omni reset 7A3FDF94-DDAC-42F4-B221-695F4F313DE9.pngthe speed to 75%.
Lights are not having same issue but I deleted the schedule for them when I tried to reboot just to see.

i think there is a clitch in the schedule system . When they set the pool up at first it was at 75% for 12hrs . Wonder if it keeps referring back to that schedule even though I deleted it a week ago
 

joboo7777

Bronze Supporter
Aug 8, 2020
243
McKinney, TX
Pool Size
15568
Surface
Plaster
Chlorine
Liquid Chlorine
I have seen some ofd scheduling issues after upgrading firmware. Not with pump or light schedules but specially with turning on my Ozonator. Not sure this will work for you but I had to disable(not delete) the schedule and reenable it when in the defined scheduled time. When you do this It should immediately activate the pump at the speed defined in the schedule.
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Found the issue!
Finally Spoke to the guy who set the Omni up.
He set it up to run at 75% when the bubblers are on. Turned the bubblers off the pump runs at what is set in the schedule. Turn the bubblers on it auto sets the pump to 75%.
 
  • Like
Reactions: joboo7777

duckcmmndr

Bronze Supporter
May 7, 2014
346
Arkansas
Pool Size
29980
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
That will do it. You can modify that if you choose to do so.
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Told him I want that modified . Takes the whole purpose of the variable speed pump away . We have to run the bubblers when the pumps on to keep the tanning ledge from getting stagnant .
 

duckcmmndr

Bronze Supporter
May 7, 2014
346
Arkansas
Pool Size
29980
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite (T-15)
Told him I want that modified . Takes the whole purpose of the variable speed pump away . We have to run the bubblers when the pumps on to keep the tanning ledge from getting stagnant .
I don't have bubblers on my tanning ledge and it's stays crystal clear just like the rest of the pool. The wind and current from the returns keep that water stirred up just fine. I don't even have dirt collect up there like I was worried about. I simply brush it when I brush the rest of the pool.
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
That will do it. You can modify that if you choose to do so.
Deleted the set pump rate on the bubblers and my schedules work now as it should .
Thanks very much for your help!
this forum may be the most informative of any type I have ever been on .
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
44,310
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
this forum may be the most informative of any type I have ever been on .
We are glad you have found our information helpful. Please, if you can, consider making a donation to TFP. We are staffed by volunteers and are registered as an IRS 501 (c) (3) charity and donations are what keeps the forum operating without advertisements.

Support TFP!
 

ElPollero

Silver Supporter
Jul 14, 2021
24
Tennessee
Pool Size
34491
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
We are glad you have found our information helpful. Please, if you can, consider making a donation to TFP. We are staffed by volunteers and are registered as an IRS 501 (c) (3) charity and donations are what keeps the forum operating without advertisements.

Support TFP!
Will do . Actually glad you linked this for me. I feel it’s an obligation for me after all the info I found here in just 2 wks of having a running pool.
Thanks
 

PoolBrews

Well-known member
Oct 16, 2019
362
The Villages, Florida
With regards to the bubblers - you can create a theme called Bubblers that turns on the bubblers and sets the pump to 75% (or whatever you want). You can then run the bubblers using the theme - just turn it on or off when desired. The pump will return to the set speed in the schedule when the theme is turned off.
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread