OnlyBelieve

Member
Sep 10, 2021
10
Nashville, TN
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
I’m a pool rookie and need help figuring out if a technician sent out by First American Home Warranty did something wrong. I bought this house with an inground 20x40 pool in Sept. 2020. In April I started getting the “Check System No Cell Power 2” on my Hayward Aqua Plus display. The assigned tech called me and asked for pics of the display error. After getting the pics, he said he would order a new board and a new Pentair variable speed pump. After he received them, he made his first visit to my house and installed them. Before he came to my house, my pool was flowing with no problem, my heater could be controlled through the display, the chlorinator worked through the display, and the lights - a pretty bluish-purple color - came on automatically each night. After he left, the water in the pool stopped flowing and started turning green, the heater couldn’t be controlled on the board anymore, and the lights don’t come on at all - even when I try to turn them on manually. The display didn’t even working correctly. So, the tech said I now needed a display and that he could sell me one. This didn’t sound right, so I paid a different company to come fix it. They put a new display on and it didn’t work either so they said the display isn’t the problem and that it must be an incompatible board that was installed. They put my display back on and wired my pump outside of the board so that my pool could circulate. After that, the original tech came back out to install a different board. However, when he showed up, he came to my door with an open box and said he just realized the company had sent him a display instead of a board. He said he would be back again after he got the right thing. About 15 minutes later, I realized he was still at my house doing something with the equipment again. I asked what he was doing and he said he was taking the board since it didn’t work. He came back a few weeks later and installed another board. After that, the display worked but the down arrow didn’t work on my display anymore. After all of this, the lights don’t work, the heater doesn’t operate through the display, and it seems as if the chlorinator doesn’t automatically operate anymore, and the filter isn’t controlled through the display. I’ve also battled with algae all summer, whereas before, the pool was a beautiful clear blue with no problem. It feels like the tech messed something up and I don’t want more problems when it gets cold. I want my equipment nice and easy like it was when I bought the house a year ago. What does it sound like the problem is? What should I do now to get my pool equipment going right again?

FYI - My warranty with First American will be up next week, on Sept 15. They told me today that they will not allow me to renew my policy. I guess I’m seen as a bad customer because I actually had to use it.

Thanks in advance.
 

Attachments

  • B7A8A899-4171-49A9-B5A0-56B1BD4475C6.jpeg
    B7A8A899-4171-49A9-B5A0-56B1BD4475C6.jpeg
    268.6 KB · Views: 4
  • 435E806C-CEA5-4158-973C-05E92DE3E983.jpeg
    435E806C-CEA5-4158-973C-05E92DE3E983.jpeg
    405 KB · Views: 4
  • D6549A97-D4C9-40F1-8391-D881291E21B9.jpeg
    D6549A97-D4C9-40F1-8391-D881291E21B9.jpeg
    441.5 KB · Views: 2
  • C53AE8B8-2EC7-4E85-B6CD-FF2B6FFBB0D7.jpeg
    C53AE8B8-2EC7-4E85-B6CD-FF2B6FFBB0D7.jpeg
    364.8 KB · Views: 3
  • 3C5B40C9-10DD-4994-9667-646C2451E14C.jpeg
    3C5B40C9-10DD-4994-9667-646C2451E14C.jpeg
    700.8 KB · Views: 2
  • D7D02C0A-F720-4035-B427-9B95AFB9AFC2.jpeg
    D7D02C0A-F720-4035-B427-9B95AFB9AFC2.jpeg
    739.1 KB · Views: 3
Last edited:

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
29,877
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Post pics of your Aquaplus box showing the board and wiring so we can see what is in there now.

Also post pics of the Pentair pump showing the labels on the front and sides.

Are you sure the tech properly setup the software configuration in the new board?
 

OnlyBelieve

Member
Sep 10, 2021
10
Nashville, TN
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Post pics of your Aquaplus box showing the board and wiring so we can see what is in there now.

Also post pics of the Pentair pump showing the labels on the front and sides.

Are you sure the tech properly setup the software configuration in the new board?
I’m not sure how to show the wiring. Do you mean open the board up to see how it’s wired inside?

The tech didn’t know how to program it. He was Googling and calling tech support.

Yesterday, someone said a Pentair pump won’t work with a Hayward board. Is that true?

Thank you!
 

JamesW

TFP Expert
Mar 2, 2011
28,291
Yesterday, someone said a Pentair pump won’t work with a Hayward board. Is that true?
Yes, that is true.

The person is incompetent.

The initial service call did not indicate any problem other than the circuit board, which could probably be fixed.

What was the reason given for the need for a new pump?

In any case, the pump should have been a Hayward variable speed pump to allow it to communicate with the automation.

What is the software revision number?

What are the first 7 of the box serial number?

It should start with something like 3L and it is next to a barcode on the door label.
 

OnlyBelieve

Member
Sep 10, 2021
10
Nashville, TN
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
Yes, that is true.

The person is incompetent.

The initial service call did not indicate any problem other than the circuit board, which could probably be fixed.

What was the reason given for the need for a new pump?

In any case, the pump should have been a Hayward variable speed pump to allow it to communicate with the automation.

What is the software revision number?

What are the first 7 of the box serial number?

It should start with something like 3L and it is next to a barcode on the door label.
3L15016
 

JamesW

TFP Expert
Mar 2, 2011
28,291
OK, that will run a Hayward variable speed pump.

I would ask them to replace the pump with a Hayward for proper control.

Can you check the software revision number?

It should look like this.

1631308919021.png
 

OnlyBelieve

Member
Sep 10, 2021
10
Nashville, TN
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
One more question. I just got rid of yellow algae last week. Is it ok to use the same brush I was using before or will that “reinfect” the pool with yellow algae again?
 

Enjoying this content?

Support TFP with a donation.

Give Support

JamesW

TFP Expert
Mar 2, 2011
28,291
Make sure that the brush is rinsed out well.

Maintain the FC slightly elevated for a while as a precaution.

I would suggest an FC/CYA of about 15% to 20% for a week or two if you have any reason to be concerned about mustard or other algae.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread