Hayward 500lb sand filter leak

RJL

Member
Jun 8, 2015
10
Manahawkin, NJ
We have a Hayward pro series 500 lb sand filter. Had the sand and laterals changed out 2 or 3 weeks ago. Now there is a split on the seem that runs the length of the filter, top to bottom that's spewing water. It's a 15 year old unit. I'm thinking the people that changed out the sand had something to do with this, in the past have always done all the work myself, figured I'd take a break and let the professionals handle this little job. Never again.

Anyway, is there some type of epoxy I can put in the seam to get the fall until I change out the filter? Just gonna need a housing as I have new laterals and new sand. Can I re-use the sand?

Any advise would be greatly appreciated.

Bob
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
22,036
Laughlin, NV
Discontinue use of the filter immediately and replace it. This is a pressure vessel. It cannot be repaired.

If you can find a housing, then you can reuse the internals and sand.
 
  • Like
Reactions: RJL and JamesW

RJL

Member
Jun 8, 2015
10
Manahawkin, NJ
Discontinue use of the filter immediately and replace it. This is a pressure vessel. It cannot be repaired.

If you can find a housing, then you can reuse the internals and sand.

Thank you for the quick response. Gonna start searching for a new housing. I used a product called "water weld" put that water proof tape you see on TV over the weld product. Got it to stop spewing out water. Now just leaking. Gonna operate the filter a few hours a day like this until I can get it fixed so I don't lose the pool to algae.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
22,036
Laughlin, NV
My recommendation stands -- take this filter out of service now. If it catastrophically fails, you can hurt people or damage other equipment / house/