Haward Super Pump Humming

creena

New member
Jul 9, 2008
2
After opening the pool this week I noticed that the pump occasionally hums and the impeller fails to turn when started. The unit shuts itself off after about 15 seconds due to, I suspect, overheating. I replaced the capacitor and the issue remains unresolved. If the motor is gently tapped when it is humming, the motor starts.
Is the motor toast and if so any recommendations for a replacement?

Thanks,
Andy
 

Bama Rambler

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2009
23,062
SouthWest Alabama
Sounds like the start switch. It'll be right at the back of the motor if you pull the cover off (after turning off the power!). You can try to sand the contacts a bit and lubing the pivots with dielectric grease. don't use too much though. Or you could take it to a motor shop and have them replace it.
 

Isaac-1

TFP Expert
LifeTime Supporter
May 10, 2010
6,711
SW Louisiana
I had to replace a burned out motor on a 1.5 hp super pump about a month ago, the replacement was an AO Smith labeled motor from Pool Plaza in Texas, I don't know if they have the best price, but it was better than a couple of other places I checked, and the shipping was very fast ( I ordered around 3 pm one day and it arrived here the next, they are in Dallas about 300 miles away). It was easy to swap out, maybe 30 minutes tops, no need to unhook any of the plumbing.

Ike.
 

creena

New member
Jul 9, 2008
2
Thanks for the speed replies. I'll try cleaning the start switch and take it from there.

Andy
 

Other Threads of Interest