Have I diagnosed this filter issue accurately?

Dead Waters

Member
May 30, 2016
11
Belfast, Maine
Hi All, and thanks to this community for getting me started trouble free. I've been enjoying my pool for a few years now, while monitoring a filter leak with a gradually increasing
flow around the filter top. The pump no longer maintains a seal, and the filter basket housing loses much of its water after the pump shuts off. As you can see, the steady leak has deteriorated the settings decal to the point that I had to remove it. So, my question is, does this look like I need a new spider gasket? If so, what source on the web would you recommend for parts? Thanks for taking the time to read this.

Dead

et?IMG_5140.jpg
 

Shirker

Well-known member
Jul 2, 2014
689
Athens, GA - USA
Pool Size
19000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
It would have to be pretty far gone to leak so much that your pump loses prime. Water only leaks out where the handle is? I would start with the spider gasket for sure. Hopefully that is all it is but if you still have a leak, it will be easier to trouble shoot knowing the gasket is good.
 

Dead Waters

Member
May 30, 2016
11
Belfast, Maine
It would have to be pretty far gone to leak so much that your pump loses prime. Water only leaks out where the handle is? I would start with the spider gasket for sure. Hopefully that is all it is but if you still have a leak, it will be easier to trouble shoot knowing the gasket is good.
OK, Thanks, Shirker. I'll go ahead with the spider gasket replacement.