Forgot to add DE right after cleaning my filters...problem?

TFP_Addict

Well-known member
May 19, 2015
108
Burbank, California
Been dealing with some algae and saw the pressure shoot up to 20 from 15, and figured it was related. Took my filters out, they were clogged with algae, so I cleaned them.

By the time I finished it was dark out and I totally forgot to add the diatomaceous earth. The filter then worked the next day for about 3 hours until It hit me that I forgot.

So I opened my filter, it seems basically still extremely clean, and closed it and then added the DE into the skimmer.

So I guess my question is. I know I need to use DE, I'm just not sure what it does exactly. I'm assuming it's to help the actual filters work effectively? or work at all? I'm not sure.

What are the effects of not adding the DE right after reassembling your filter and get it started.

Should I be worried? Or ...
 
Last edited:

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
If you ran the filter for a short period and the water was relatively clean, you should be okay. But you want to avoid running grids without DE because they can get debris embedded inside them. Once that debris gets lodged in the pores of the fabric, it can be next to impossible to clean. Nothing like rinsing a paper cart filter.
 

TFP_Addict

Well-known member
May 19, 2015
108
Burbank, California
I could have sworn his or her sig said "cartridge filter" when I replied.
It did, Which is why I updated it, thinking there might have been some confusion there.

Edit: now that I think about it, I have no idea why I wrote cartridge filter at all, it's a totally different system. I'm thinking its possible I only thought there were 2 kinds of filters, 1 being sand and the other being Everything else.... or something, I have no idea honestly. But long ago, I did get the exact model with the help of this website and also called pentair regarding this filter and asked a bunch of questions. I guess I just never updated my sig. So it's updated now.