Filter doesn't seem to be doing its job

napro5150

New member
Jul 18, 2016
4
Oakdale,CA
I noticed a lot of sand in my pool this weekend. The sand is from a dry well that is suppose to serve as an overflow for the autocover housing. I never ran drainage for the dry well so the rain is going through the dry well and draining into my pool. This is also bring sand into my pool as i have not put in landscaping yet. I just got through the rainy season so I am trying to clean my pool water. I ran the pump all day Saturday and Sunday but the water seems to be getting worse in clarity and looks dirtier (if that is possible). Before I cleaned the cartridge filters before I started the filter on Saturday. The filter has been running at about 15 psi. I am a new pool owner and pretty sure something is wrong but don't know where to start. I am using a Zodiac MX8 to vacuum my pool. I actually took it to Leslies pool to make sure it wasn't broken. It is fine and in good working order. Please help!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
11,420
Bedford, TX
napro,

Welcome to TFP.. A Great resource for all your pool questions... :testkit:

Water clarity issue can be many things, so the very first thing everyone here will want to know is what are your testing results..

FC
CC
pH
TA
CH
CYA

Let us know and we'll see what we can do to help.

Thanks for posting,

Jim R.
 

napro5150

New member
Jul 18, 2016
4
Oakdale,CA
Thank you for your help. These are the results

Free Chlorine: 2 ppm
Total Chlorine: 2 ppm
Calcium Hardness: 120 ppm
CYA: 10 ppm
Total Alkalinity: 90 ppm
pH: 7.8

I also bought Clear aid from Leslie pools. I didn't want to but I was desperate. I just put it in and no visible change but the bottle did warn that if the pool temp was below 70, it would take more time than usual.

Any thoughts
 

Other Threads of Interest