False salt readings

DanaC

New member
Aug 28, 2021
1
Houston
Hi,
I am a homeowner just trying to keep my pool running smooth and clean for my kids and grandkids. I changed my T-15 cell recently and the salt amps show 4200 while the pool store shows my salt level at 3200. I cannot seem to recalibrate the level, so my chlorine is not generating and the pool keeps getting algae. I don't have the same equipment shown by others, so I cannot just click on the diagnostic button five times to get it to recalibrate. I have a Gold Line Aqua Rite AQL-PS-8-X295 which is shown in the photos attached. Can someone tell me how to recalibrate the salt reading? Thank you!
 

Attachments

  • 024.JPG
    024.JPG
    424.9 KB · Views: 3
  • 025.JPG
    025.JPG
    377.5 KB · Views: 3

mas985

TFP Expert
LifeTime Supporter
May 3, 2007
14,810
Pleasanton, CA
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
Welcome to the forum!\

Your unit is an AquaLogic not an AquaRite correct? AQL-PS-8 is an AquaLogic model # and the display looks like an AquaLogic.

The Hayward system does not really recalibrate. It only replaces the average salt level with the instantaneous levels. That generally does not solve anything anyway unless the salt level is too low.

Is the unit giving an error (yellow light)?

What are the unit instantaneous readings (temp,volts,amps,salt)? Diagnostic menu then right arrow.
 

JamesW

TFP Expert
Mar 2, 2011
28,291
Go to the diagnostic screen, note the readings and then press the + button to reverse the polarity.

When the new numbers appear, see what they are.

Then, press + again and note the new readings.