Excel Pro 24" Sand Filter

Dadof6

Member
Sep 20, 2016
11
New Braunfels
I have an Excel Pro 24" Sand Filter - less than 1 year old. I have just now started getting sand in my pool, definitely from the filter (CYA went straight to the bottom of the pool when poured in the skimmer). I took it apart and cannot see anything wrong with it - no cracked or broken parts, no channeling, 6 way valve appears to work as designed. I originally put 300# of sand in as directed. When opened it was only a little further than half way full. Can you lose much sand from backwashing? Why would it start failing to filter after working well before? Any help is much appreciated.
 

jblizzle

Mod Squad
TFP Expert
LifeTime Supporter
May 19, 2010
41,195
Tucson, AZ
CYA passing directly into the pool (which is really bad to be sitting on your liner ... you need to be brushing it around and getting it to dissolve or get it sucked into the filter) sounds more like a multi-valve problem than a filter problem. Is it set to Filter?
 

Dadof6

Member
Sep 20, 2016
11
New Braunfels
I had already removed the CYA from the bottom of the pool, I was just using it as an example of what it is doing. And yes, it is and has been set to filter. I took apart the multi-valve before diving into the filter components - the spider gasket and spring look fine and the handle on top is secure. Is there anything else I can do to troubleshoot it?
 

jblizzle

Mod Squad
TFP Expert
LifeTime Supporter
May 19, 2010
41,195
Tucson, AZ
Nope. Only way for anything you add via the skimmer to go back to the pool is a problem in the multi-valve allowing the filter to be bypassed or a problem in the filter itself.
 

Other Threads of Interest