EasyTouch Nightime Cooling

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
OK, so I *think* I have my solar cooling enabled.

Max temp set higher than Set temp in Heat menu.

But my questions are:


  1. Will the set point trigger also start up the pump?
  2. How do I get the pump to kick on if/when the array is cool enough, but not turn on if it is not
  3. Can I just sent 4 hours of cooling late at night [my preference].
  4. If the pump needs to be running, is there a way I can enable/disable a late night schedule [say 2-6 AM, but only when the "Cool" button is pushed?]
  5. And/Or, if it is not cool enough to cool, can I avoid running the pump?
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
OK, now Im stumped.

Once I switch to Night time cooling in the solar menu, the solar valve actuates no matter what temperature setting, and that is with the roof sensor saying it is too cool for heating.

I turn off nighttime cooling, actuator goes back to off.

I guess I'll do some searching on nigh time cooling.

Any Pentair experts out there?
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Now it is working correctly [but sensor says the panels are hot enough for heating now].

And the Max temp won't remain programmed.

Every time I check it, it reverts to 0 degrees.

I set it to 75, it seems to take, I can exit out of all the menus, go back, check it, and it is back to 0 degrees.

I find this behavior when I try to calibrate the temp sensors. I have to try sometimes may times, and power cycling the entire system *seems* to more than not make a setting take.

Any ideas?
 

pooldv

TFP Expert
Platinum Supporter
LifeTime Supporter
Moderator Emeritus
Aug 10, 2012
25,412
FL panhandle
When I want to cool I run the pump at 1100 rpm from 8p to 10a. On the Solartouch i have to enable solar cooling which I assume disables solar heating. Then set the water temp to 88 or whatever temp I am aiming for.
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Ok, that helps. I think it may be that some settings don't take right away. If I remember to start the pump tonight, I'm going to see if it works.

Sounds like it will do what I want, mostly, if I can figure out how to make it work.

I have max them set to 75, so it should cool until it reaches that.

Thanks!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,950
Bedford, TX
xyz,

Not sure I can help at all but I have a couple of questions...

Do you have ScreenLogic or are you using the 3" display at the panel?

What is your Solar Temperature Differential set for?

Seems to me there are a lot of variables that need to be met in order for this to automatically work...

The Water Temperature must be above your temperature set-point by at least the differential amount and the Solar temperature must be below your water temperature by some differential amount.

How hot is your pool water at night? How cold does the solar output become?

I can't say I have ever seen my EasyTouch not take a parameter on the first try.

I don't have solar, so buyer beware... but maybe we can stumble on to something..

Thanks,

Jim R.
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Thanks Jim!

So I am using both the front panel display and screen logic.

Ive got about an 8 degree delta between starting pool temp and max gem in the heat menu.

I *think* all is now good, it seemed to work last night with the exception that I used the wrong pool setting with too low am RPM, so I lost flow after a couple hours. So when and *if* I can get max gem to take, it seems to work (cool).

So with particular parameters, I can have trouble with either the front panel display, and screen logic, or more specifically SL config. The two parameters I've found that won't "take" are temp calibrations p, and max temp. I can set them over and over, and they seem to hold, only to exit out of the menus, go abc and they are back to their original settings. Power cycling seems to help, but not a for sure option.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,950
Bedford, TX
Jon,

Are you using your phone or PC to program ScreenLogic?

Using my PC, I just changed my air temp calibration 8 times and it seemed to work each time. It was the same in the full screen app and the configuration app.

Glad you got it "almost" working...

Thanks,

Jim R.
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
All 3 for temp cal. Computer, SL config, or front panel. It will take, but not readily.

Max team is not available on the computer screen, I believe this is a bug that Pentair acknowledges, but has not had enough people complain about.

Sometime me I feel like I would be best off resetting completely and reprogramming from scratch. But since I have only done modifications, I might not get it back to the way I want it.

I guess with with this site, I have life lines. So maybe that is the next step?

- - - Updated - - -

Oh and failure again last night. Turns out cooling mode will only activate when "pool" is used. I used a separate circuit (called it "Cool" in a schedule. But without "Pool" it didn't activate the solar valve.

Is is there a simple way to make a circuit engage heating and cooling? Or is my only option to use "Pool"?

i don't want to us "Pool" because then that runs my SWG, and I get crazy high FC. and I don't want to turn down my SWG, because I only want to Cool when I need it.

- - - Updated - - -

Full screen app vs configuration app? What is the difference?
 

Enjoying this content?

Support TFP with a donation.

Give Support

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,950
Bedford, TX
Jon,

I was just trying to differentiate between the Configuration Pages vs. the normal ScreenLogic Operating Pages..

I'll play around with it later today and see if I can come up with something... maybe, maybe not... we will see.. :p

Thanks,

Jim R.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,950
Bedford, TX
Jon,

Well I've got bad news and some slightly not quite as bad news... :p

I can't see anyway around the fact that the pump needs to be running in the Pool/Spa mode to enable solar to work at all..

But I have two ways to make it not matter..

1. The easiest fix is to just run your pump 24/7 and then turn the cell down to compensate for the additional run hours. Might not work where you are , but for me, I run my IntelliFlo, 24/7, for less than $20 bucks a month.

2. If you have an unused relay, which with an ET8 I would assume you have, you can remove the existing relay which only has Normally Open contacts and replace it with one that has both Normally Open and Normally Closed contacts. As an example... If you replaced Aux 8.. then you could run the AC power to the SWCG's transformer through the new relay's NC contacts.. This would mean the cell would work like normal unless Aux 8 was energized. When you want the cell off, you just schedule Aux 8 to be on... The down side is you would have to kluge a relay of your own or use Pentair's 2-speed relay, which is about $100 bucks, but does have the advantage of plugging right into the PCB and mounts into the chassis like a standard relay.

I played with "Solar" on my system today using a spare actuator, spare temp probe, and a container of ice water and hot water.. It appears to me that you don't really have to schedule anything for cooling to work. You enable cooling and set the MAX temp (which as you say, is not in ScreenLogic) to say 75 degrees and then anytime the water in the solar panel is below the temperature of the pool water the valve opens.

Not sure that helps with your predicament or not, but it is the best I've been able to do so far..

Thanks,

Jim R.
 

pooldv

TFP Expert
Platinum Supporter
LifeTime Supporter
Moderator Emeritus
Aug 10, 2012
25,412
FL panhandle
More info on how my Solartouch works in case it helps with the Easytouch.

Yes, the pump needs to be on, I run mine from 8a to 10p when heating and from 8p to 10a when cooling it runs at 1100 rpm which uses 150 watts and is enough flow for my skimmers to work and the SWG to make chlorine. When solar temp is warmer (or cooler) than the water temp then the valve opens and the Solartouch moves the Intelliflo to external control speed 2 (1950 rpm for me). Knce the pool water reaches the set temp the valve closes and returns the pump to 1100 rpm.
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Completly awesome guys.

So in that what I want can't be done, is good news because I won't chase the white rabbit any longer. I do have a DPDT relay I could use to make my own custom mode. I think I just have the relay swap the red and white wire, and that swaps the sense of the actuator. I was originally planning on this hot rod mod before I discovered the cooling mode. So I'm probably going to just do the hot rod. Then I have both options available. The only other approach might be to use the relay to turn off the Swg with a relay, but that seems like I'm getting a bit too tricky for my own good.

What at I don't like about running day and night is that I'll have to adjust my SWG every time I want to cool. VS just enabling the days I want to cool.

No info on the setting not "taking" though. I guess maybe it is time to while it clean and hope I can reprogram it from scratch.

It it would seem if I Take screen shots of all the configure settings in the config computer app, I should be able to restore what I have. Right?

- - - Updated - - -

Oh, I see you meant for me to use a relay to disable SWG, NOT actuating the valve. I don't understand why I'd need a DPDT relay for that. The existing relay will enable/disable SWG power supply easily, right?
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
17,634
Tucson, AZ
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Someday Pentair will make an automation system that isn't locked into 1980's-like programming methodologies....any feature circuit should allow you to be able to attach a speed, a function and a temperature to it. Oh, and the fact that there is no integrated WiFi and/or Bluetooth into the personality board is criminal in this day and age (my 2 year old $80 HP printer has direct connect via internal WiFi....).
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
20,950
Bedford, TX
Oh, I see you meant for me to use a relay to disable SWG, NOT actuating the valve. I don't understand why I'd need a DPDT relay for that. The existing relay will enable/disable SWG power supply easily, right?

xyz,

The normal relays that come with the ET have to be energized for the connections to be made. To use one of the original relays you would have to keep it energized most of the time and only turn it off when you want the SWCG off. It makes more sense to use a DPDT relay which will allow the SWCG to run when the relay is not energized. This makes scheduling much simpler as you just have to turn the relay on when you want the SWCG off.

Thanks,

Jim R.
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Appreciate that discussion, helps me to pull the trigger on doing this hot ridding. I think I'm mostly settled on just using a DPDT relay to swap the sense of the valve, so at night I can have a "Cool" Mode that will also actuate the valve.

Now if if I can just figure out why some parameters won't "take."
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
17,634
Tucson, AZ
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Now if if I can just figure out why some parameters won't "take."

I've seen that happen with the EasyTouch remote I have. It's a glitch in their programming where you have to scroll off the current field you're in and then back out of the menu you're in. Something about leaving the cursor active in a newly changed field that causes the system not to take the parameter.
 

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
17,634
Tucson, AZ
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I've seen that happen with the EasyTouch remote I have. It's a glitch in their programming where you have to scroll off the current field you're in and then back out of the menu you're in. Something about leaving the cursor active in a newly changed field that causes the system not to take the parameter.

That's what happens when your programmers and technical engineers are all retreads from the 1990's....
 

xyz

Gold Supporter
Sep 8, 2016
641
Escondido/CA
Ok, I hooked up a DPDT relay, created a "Cool" mode, and set it up for the next few nights. Let's see how cool I can get.

I went with an 8 dollar relay vs Pentair. I used the relay to swap the red and white valve actuator wires. Then set cool mode for the right RPM, and scheduled for when my array is typically cooler than the pool water by a good margin.
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.