EasyTouch adds 10 minute shutoff delay

Rocket J Squirrel

Silver Supporter
Bronze Supporter
Jun 7, 2018
1,242
Alamo, CA
Pool Size
36000
Surface
Plaster
Chlorine
Liquid Chlorine
My EasyTouch 8 is scheduled to turn off the pump at 4:00 pm daily. Every day, it remains running until 4:10 with DEL showing in the display. I have no circuits running (or recently run) other than Pool. Occasionally Solar kicks in. I can't figure out why I have this unwanted 10 minute delay every day. I'm pretty sure it didn't do this last season.
 

yblaser

Well-known member
Apr 21, 2010
46
Torrance, CA
I experienced the same thing when I had the cooldown setting enabled and ended up disabling it. I noticed it when I manually turned on the pool circuit briefly to check out some equipment and then it wouldn't turn off. It took me a while to notice the DEL on the screen. I have solar as well. Solar was enabled but never activated during the brief runs since it was in the evening.
 

Rocket J Squirrel

Silver Supporter
Bronze Supporter
Jun 7, 2018
1,242
Alamo, CA
Pool Size
36000
Surface
Plaster
Chlorine
Liquid Chlorine
I thought Cooldown only applied to the gas heater, which has not been running at all.
I apparently thought wrong. I exchanged emails with a Pentair rep , who said
The heater cool delay is not a bug, that’s intentional and will keep the pump running 10 minutes after whether the heater was on or not.
I experienced the same thing when I had the cooldown setting enabled and ended up disabling it.
Yep, apparently they all do that. I also disabled the delay on mine.
 
  • Like
Reactions: ogdento
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread