Easytouch 8 spa blower won’t turn off and off occurrences

Julie8000

Member
Oct 23, 2017
21
Houston, Texas
Will try to make this short but weird things have happened. We were part of the big storm had 12 hour power failure but all started up fine.but all seemed to work correctly although the remote was sometimes acting up. Easytouch 8 is 15 years old
  1. Few days ago spa light and spa was on for no reason. Light was on on the remote but wouldn’t turn it off.
    husband punch buttons, nothing and then I tried repeating on the remote in the remote settings as delay was showing so I hit cancel delay and it turned off.

  2. yesterday we had our sprinkler guy look at the auto fill valve which had not been working for a year. He said it was the solenoid and told us how to fix it. The auto fill is on a different circuit and had a program set. (Hasn’t worked in months). He was able to run water to fill bt turned off and disconnected the solenoid for us to get a new one.

  3. Today the spa blower was on for no reason. when I noticed the blower was on it was when the water fill program was set so that showed on but no water filling as the solenoid was out and not replaced. Maybe just a coincidence as to when I noticed the spa blower was on. It was not lit on the remote. Then it was. My husband tried service etc. still nothing would turn off. He turned off the breakers in the garage and when it came back on was still is running. There are no schedules set for the blower at all.

  4. so we can’t turn off the spa blower. It doesn’t show on remote as on. Any suggestions? We are not too good with anything complex. I don’t have any troubleshooting apps etc.
Any help would be greatly appreciated

julie
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,797
Bedford, TX
Julie,

If you have a wired pool side remote, I'd unplug it inside the EasyTouch and see what happens..

For the blower to run, an Aux relay has to be closed.. It could be the Aux relay is stuck.. Hit it with the plastic handle end of a screw driver and see if the blower shuts off.

If that does not work, you can just disconnect the load side of the Aux relay that controls the blower.. With the power off first of course..

Thanks,

Jim R.
 

Julie8000

Member
Oct 23, 2017
21
Houston, Texas
Jim

We only have a wireless remote. since I posted it mysteriously stopped. But given the strange things occurring who knows. But if it does it again, what would I hit with a screwdriver If I have a wireless remote and where if I should still hit it.

thanks.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,797
Bedford, TX
Julie

Show me a pic of your EasyTouch with the door open, and then another pic with the circuit breakers and relays exposed...

Basically, one of your Aux buttons on the main unit should say blower or something like that.. As an example, if Aux 1 is labeled "blower" then you would hit the Aux 1 relay..

The relays should be in sequence starting with the upper left relay as follows..

Pump/Filter relay, then Aux 1, 2, and 3 on the top row... then Aux 4, 5, 6 and 7 on the bottom row..

I would look something like this...




Thanks,

Jim R.
 

Julie8000

Member
Oct 23, 2017
21
Houston, Texas
Julie

Show me a pic of your EasyTouch with the door open, and then another pic with the circuit breakers and relays exposed...

Basically, one of your Aux buttons on the main unit should say blower or something like that.. As an example, if Aux 1 is labeled "blower" then you would hit the Aux 1 relay..

The relays should be in sequence starting with the upper left relay as follows..

Pump/Filter relay, then Aux 1, 2, and 3 on the top row... then Aux 4, 5, 6 and 7 on the bottom row..

I would look something like this...




Thanks,

Jim R.
I will have to get my husband out there for a picture. Now the spa is running again no light on etc.
 

imrodee

Gold Supporter
LifeTime Supporter
Jun 23, 2012
1,050
Waxahachie, TX
Pool Size
16000
Surface
Plaster
Chlorine
Liquid Chlorine
SWG Type
Pentair Intellichlor IC-40
Did you ever figure this out?
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.