Dolphin Sigma stuck on Hayward main drain

Davrx

New member
Jul 9, 2020
4
Ohio
I was looking for information on what to do to prevent my Sigma from continually getting stuck on my main drain. Nothing has helped so far, I've tried running the robot at its fastest setting, using main drain clip-ons that were promptly removed by the robot, and the Zodiac 5820 Unibridge Main Drain Cover which the robot just pushed out of the way. The clip ons and the Zodiac were suggestions from Dolphin. I even placed suction cups on the bottom of the Zodiac but that didn't work either. There were a couple people that cut the center out of their Zodiac on an earlier thread from 5/19/16 but I never saw a follow up as to whether this worked or not. I plan on trying this myself to see if it works.
I also purchased a low profile drain by Aquastar LP8AVWR101 to replace my current Hayward WGX1048E which was also part of the 2016 thread but also never saw a follow up as to whether it worked or not. The Aquastar only has about a 1/2" lower profile than my Hayward so I'm skeptical if this will work. Before I rent some scuba equipment I'd like to see if the Aquastar did the trick.
 

Davrx

New member
Jul 9, 2020
4
Ohio
The Zodiac with cut out center worked. Finally found something to keep my robot from getting stuck on the main drain!
In light of the discontinued SmartPool Smart Ring, this is probably all there is to fix this issue unless the Aquastar works, which I'm not going to mess with since the modified Zodiac is working.
 
Last edited: