Dolphin S200 not cleaning entire pool...

gdog2004

Well-known member
Jul 19, 2011
240
Lehigh Valley, PA
Hi guys:
I have a Dolphin S200 less than a year old that I bought from Marina Pool. it is still under warranty but I would like to try and fix before sending it back.
The issue is that it will not clean the deep end of the pool (where the end of the pool is and the bottom of the pool and wall meet.
I have run it 3 or 4 times(with a clean filter every time) and it will not clean it. It seems to clean the rest of the pool, but not that.
Any ideas what the issue could be ?

G
 

Oly

Gold Supporter
Jun 28, 2017
1,693
Fresno, CA
Have you run it for more than 2 hours during a cleaning? No issues with cord length due to available plug? How deep is your pool? Bottom drain? What happens when it approaches the deepest area?
 

gdog2004

Well-known member
Jul 19, 2011
240
Lehigh Valley, PA
Have you run it for more than 2 hours during a cleaning? No issues with cord length due to available plug? How deep is your pool? Bottom drain? What happens when it approaches the deepest area?
I let it run until it shuts off. No issues with Cord length, the unit has never come close to using even half of the cord(it is 75 feet long cord). I do not have a bottom drain. I turn the pump off when I run the robot. The pool is 7.5 feet on the deep end.
Before it gets to the dirt at the bottom end, it just stops and goes in another direction. It does not reach the back wall at the furthest end. It used to, but not any more. I have only been using it for 3 months.
 

Oly

Gold Supporter
Jun 28, 2017
1,693
Fresno, CA
Strange if you do not see it in the deep end or climbing the far wall. :scratch:
My pool is 17 x 37, similar depth and often I will start the bot again after a 2 hour run because it has missed areas. Maybe try a longer run.
 

markayash

Gold Supporter
Mar 21, 2016
2,697
Atlanta Ga
I owuld check the propeller and make sure it's not clogged up..Also take the swivel apart and make sure it's hasn't got any water or dampness on it.