Dolphin m4 problem

phild

Member
Jul 27, 2010
21
Hi.

I have a dolphin m4. The controller turns on, lights up etc, but when I press the button to move the cleaner nothing happens. I assume the motor is blown?

How do I diagnose the problem?

Thanks
Phil
 

Captain 776

Bronze Supporter
May 2, 2016
165
Thailand
How long have you had it? Does the place you bought it have the expertise to diagnose the issue? Send Maytronics an e mail and ask them for their manufacturer recommendation.

I bought an S-1 and I think it is fantastic, even when my pool looks very clean and I let it do a 2 hr cycle the filter frames come out black and catch so much you can see. I swear by it. When I bought mine they had a promotion where you get an extra fine filter basket in addition to the just the basic screen. I also like that it is self contained and all that it catches never enters your main filter.

let us know how you make out with this.

I know of another S-1 problem where the machine will not climb the walls but have no resolution yet.

Bruce
 

phild

Member
Jul 27, 2010
21
I've had the cleaner three years I think. It gave out at the end of last season.

I bought it on line, so no real help there.

One of the reasons I bought this particular model was because I believed it could be maintained by the user. I.e. Parts could be swapped out etc.

I'm surprised no one here has had to diagnose one of these or replace the motor etc. ?

Phil
 

Geebot

Well-known member
Aug 19, 2013
934
My first guess is always the power supply. Do you know anyone with a similar unit that you can borrow?
 

pooldv

TFP Expert
Platinum Supporter
LifeTime Supporter
Moderator Emeritus
Aug 10, 2012
25,412
FL panhandle
I've had the cleaner three years I think. It gave out at the end of last season.

I bought it on line, so no real help there.

One of the reasons I bought this particular model was because I believed it could be maintained by the user. I.e. Parts could be swapped out etc.

I'm surprised no one here has had to diagnose one of these or replace the motor etc. ��

Phil

There probably are people here with that knowledge. Either give them some time to notice the thread and respond or do a search for previous threads in the upper right corner.

INYO Pools has lots of Maytronics how-to info and parts diagrams. Here's one, Maytronics Dolphin Supreme M4 Parts - INYOPools.com
 

BobbyR

Well-known member
Jun 1, 2013
142
Toronto, Ont
Have you tried pressing the reset button? That always fixes mine when it occasionally decides to just sit there when I press the start button.
 

phild

Member
Jul 27, 2010
21
Thank you all for the responses.

yes, tried pressing the reset button.



This is what happens:

If the cleaner is not plugged into the power supply/controller and I turn on the controller, the on switch lights up and the three 123 lights blink for a few seconds, then just the on switch is lit.

If the cleaner is plugged in then the on switch lights up momentarily (maybe a second) and then goes off.


wrt the cleaner.

The impeller at the top turns, though will not freely spin (I would not expect it to).
The tracks will turn, again not freely (I would not expect them to).

So, it appears there is nothing jamming either the tracks or the impeller.

Other thoughts?

Phil
 
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.