Doheny Discovery troubleshooting

Sarahdeakins

Well-known member
Aug 12, 2016
56
Houston TX
I’ve had The Dohenny Discovery for about 4 years. Lately it is not cleaning the pool. The impeller is clear, the filter basket is empty. Initially I thought it wasnt able to pick up debris and another user here suggested that the drain flap might have been warped. That appeared to be true, so I replaced it and have a nice seal now. The robot is now picking up debris , but it seems to really just go back and forth, over the same areas repeatedly, ignoring 90% of the pool (the truly dirty parts!). I don’t understand, the unit stays on for the whole 2 hour cycle, seems to be capable of getting around the pool, brushes the tiles and has bubbles coming out of the top of the unit. Any ideas on what’s going on with it? Trying to determine if it’s at the end of the road or worth repairing.
 
Last edited:

GregInClaremont

Silver Supporter
Jun 25, 2017
145
Claremont, CA
I'm a couple years in on my Dolphin S300i and I've noticed some reduced performance overall with its ability to get most of the pool done in one session so I decided to watch it run a bit.

What I found with mine:

The impeller had long pine needles wrapped inside, I cleaned that up.

And,

The tracks are worn down noticibly and it's no longer climbing the shelf and cleaning any of it. Instead, it sits against the steps pointed to the sky trying to get traction before giving up and retreating.

I ordered new tracks and rollers for it and will be installing them soon. Comparing the new ones I just received to the old ones on the unit and the wear is quite noticeable. I ordered the rollers as well just to do it all at once.

Just something to consider with yours.
 

GregInClaremont

Silver Supporter
Jun 25, 2017
145
Claremont, CA
I just replaced the front and rear roller brushes and both tracks today and this thing is scooting around the pool with a whole different attitude now. I hadn't realized the performance degradation but it's running differently now. I'm really happy I did the replacements. Btw, my old tracks were really loose and stretched.
 

Attachments

Neemer

Gold Supporter
Oct 10, 2017
271
Fredericksburg, VA
Mine is the same age as yours and I also have that back and forth thing going on. It still cleans the pool, but spends an inordinate amount of time doing the Texas two-step. As I recall, around the time I purchased it, some folks were having this issue and the manuf said there was a software or control board issue.
 

Killer95Stang

Well-known member
Aug 17, 2012
886
Sunny SoCal
I'm at the same 4 year mark as you and mine has worked pretty all this time. I do need new tracks, brushes, seals and a new cord. With all that needs to be replaced, I'm considering just buying a new unit and keeping this for spare parts.