Dirt coming out of the returns

Sunnydaze

Silver Supporter
Mar 8, 2021
500
AZ
Pool Size
15000
Surface
Plaster
Chlorine
Liquid Chlorine
Cartridge filter. I turned the pump off and opened the air valve to empty the pump basket. When i turned it back on, after it primed, a bunch of dirt came shooting out of the returns for about 15-20 seconds before it went clear again. It was enough to cloud the pool until it settled.

I'm guessing there's a gap that is opening up inside the filter when there's no water pressure and it seals itself back up when it's primed again. Is that likely or is there another possibile reason?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
40,261
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
It may be possible that if your filter was overloaded with dirt and that some of it settled in the filter and found its way past the carts and back into the pool. But normally the pleats do a pretty good job containing dirt. My biggest concern would be ensuring the stuff you are seeing out of the returns isn't algae. It can be hard to tell visually, and algae is very likely to blow back into the pool because of its consistency. So if you have any doubt, I would consider doing an Overnight Chlorine Loss Test first just to be sure algae is out of the equation. If you pass the OCLT, then I'd open up the filter, clean the cart(s), and check all the internal parts. Your signature doesn't specify what make/model filter you have, so you should update that too so we can relate better. If you fail the OCLT, then you know what's next - a SLAM Process. Let us know how it goes.
 

Sunnydaze

Silver Supporter
Mar 8, 2021
500
AZ
Pool Size
15000
Surface
Plaster
Chlorine
Liquid Chlorine
I'm following up because this issue persists. I definitely have no algae and have done a few oclt since my original posts.

I have no issues with the dirt until i have to release the air from my filter and take the lid off to empty the pump basket. I don't have to empty it often. Only every couple of months. But when i do, such as this morning, a giant cloud of dirt shoots out of all the returns and clouds the pool. See some pictures below. This only happens after releasing air from the filter and taking the pump lid off. It doesn't happen any other time.

The cartridges are not broken or cracked at all. Everything inside the filter looks fine. It does a great job filtering and works as expected otherwise.
20220805_074021.jpg20220805_074047.jpg
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,834
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
What cartridge filter do you have? Please update your signature.
Check to be sure the screen is in place on the top manifold.
 

Sunnydaze

Silver Supporter
Mar 8, 2021
500
AZ
Pool Size
15000
Surface
Plaster
Chlorine
Liquid Chlorine
What cartridge filter do you have? Please update your signature.
Check to be sure the screen is in place on the top manifold.

I updated it. Hayward C7020. It uses 8 large cartridges.

I'm not sure what you mean regarding screen. There is a manifold on top of the filters which plugs the top 4 openings in the cartridges and that is in place.
 

Sunnydaze

Silver Supporter
Mar 8, 2021
500
AZ
Pool Size
15000
Surface
Plaster
Chlorine
Liquid Chlorine
The only thing i can think of is that when releasing the airlock, the cartridges separate from the manifold on the bottom and dirt gets sucked into the return lines then when i turn the pump back on, the dirt is then blown out into the pool. But I don't know how to fix it because everything looks to be in order and nothing broken.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,834
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I had thought you might have a Pentair filter since you had a Pentair pump.

I will have to look at the diagram for the Hayward. Most filters have a screen at the top that protects the bleeder valve from debris. If that is gone, some can send dirty water out the returns. You do not see it except at startup after disturbing the filter as that is when the dirt is concentrated in the water left in the filter.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,834
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I could not find a 7020 on Haywards site. Their is a Swimclear 7030.
On the diagram, see the Air Relief Filter. Check to be sure you have that.
Hayward Air Relief.png
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
50,834
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Then either your cartridges are not fully seating in the manifolds or there is a failure of the manifold system somewhere or a filter is damaged. There is not to be any dirty water getting to the clean side of the filters.
 

Enjoying this content?

Support TFP with a donation.

Give Support