Debris coming off auto cover

gigi747

Member
May 2, 2012
18
Southern CA
Moved from here.
I have the exact same scenario happening. I have a new pool (new build) that has been open for about 2.5 months. About two weeks ago I started noticing the film on the water when opening my auto cover. My water has also been slightly cloudy when I first open the cover, but it clears up within a fews hours. The problem seems to be worse if I leave the cover closed for a couple days.

At first I didn't think much of the film on the water and assumed it was sunblock or something left over from a high swimmer load (why does everyone want to lather up with sunblock before they jump in my pool?). Then, I started noticing the cloudy water. I'm not sure if the cloudy water is a result of the film on the water or not.

Just to rule them out, I tested for copper and iron and they both appear to not be a factor: >0.2 and 0.0 respectively.

@akropp what brand cover do you have and how old is it, and do you have a cloudy water issue? Mine is a coverpools.

My suspicion is something is leaching out of the cover.
 

Attachments

  • IMG_7695.jpg
    IMG_7695.jpg
    487.9 KB · Views: 10
  • IMG_7696.jpg
    IMG_7696.jpg
    417.4 KB · Views: 10
  • IMG_7697.jpg
    IMG_7697.jpg
    366.3 KB · Views: 10
Last edited by a moderator:

gigi747

Member
May 2, 2012
18
Southern CA
Well today I opened and closed my cover about 6 times in succession, and each time I did, it seemed to deposit more of whatever is floating on top of my water. The weird thing now is that the process of opening and closing my cover had deposited tiny flecks of some unknown substance into my water.

I tried to capture some of these tiny unknown flecks, but when touching them with my finger, they seemed to dissolve and mix in with the film that was sitting on top of my water. Weird.

I cleaned the top of my cover with Dawn and a broom as it was slightly dirty. I pumped off the waste water. I also took out the filters of my S8M500 and sprayed them off.

Next, I took myself and a flashlight for a swim under my cover, and noticed that there was indeed some sort of foreign substance under my cover. It did not look like it was coming from my cover, but more like something that was sticking to it, more of the unknown substance.

My water is cloudy now and does not seem to be clearing up, which is odd since it would clear up after having the cover open for a few hours.

I'm thoroughly confused. At first I was thinking it was something leaching out of my cover. Now I'm not so sure.

Recap: oil like film floating on the surface of the water, chunks of an unknown substance floating in my water which appear to dissolve into the oily film when touched, and cloudy water. Anyone have any ideas?
 

gigi747

Member
May 2, 2012
18
Southern CA
Food for thought:

After about two weeks of cloudy water, and head scratching, I decided to use clarifier. This took about 2 days to clear everything up. I also ordered a new set of filters thinking that perhaps there was a tear or void in one of them. My water is still clear so I think my filters fine.

I still have the film on the water when I open my cover, and whatever is hanging out on the underside of my cover is deposited into my pool when I open the cover up.

The clarifier appears to be doing its job and capturing whatever the unknown substance is.

I had a chance to ask the installer of my cover if he had ever seen the oily film before. He stated he has seen it often, but was unsure what it was or the origin. He recommended keeping my chemicals balanced, which of course they are. He was going to inquire and get back to me.

I have a few theories:

1 - The muriatic acid is reacting with my cover. The Cover-Pools covers are made from a vinyl resin blend. A quick internet search shows that muriatic acid reacts with vinyl. I have an IntellipH in charge of dosing my muriatic acid. The film on the water and cloudiness issue was more pronounced after I had kept the cover closed for a few days. With my returns being slightly below water line as opposed to on the floor or in the lower section of the walls, it would seem that this would cause acid to contact my cover more than the traditional way of adding acid.

*(Now having had an autocover for ~3 months, I wish I had my main drain line plumbed directly back to my equipment pad and not my skimmer, as there does not appear to be any benefit of sucking water through the skimmer when the cover is closed. Even with the cover open, it makes more sense to me to keep the skimmer and main drain separate and have the ability to 'automate' each of their functions to provide more control.*

2- My pool builder played a bit of sabotage ie. something left in the plumbing. I kept an eye on him while he was completing the build/contract, and this would be just one of many screw-ups (that is another story), either unintentional or intentional. It seemed somewhat fishy that when I took over managing my pool, his chemical levels were barely in-check. Seems like an easy way to get a servicing contract: let the homeowner takeover a barely stable pool, they takeover and lose control within a month, they call back the builder for the servicing contract. It appears to me that the pool industry in general is just as shady as the auto sales industry.

3- Something is not able to be off-gassed with the cover closed, which causes it to collect on the pool surface with the cover being closed.