DE not sticking to fingers

pts15

New member
May 19, 2020
2
New York
I have been opening my pool in New York. I am using a Hayward EC50AC with the fingers. The DE is not sticking to the fingers and is just settling at the bottom of the filter. I've never had this problem before. Does anyone know what might be causing the DE to not stick to the fingers?

Thanks
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
15, welcome to TFP! :wave: Are you still struggling with the DE? Are you sure the DE is not making good contact with the finger while running and simply falling to the bottom when the pump is off? Figured I'd ask that silly questions first. Let us know how it's going, we have many DE fans here who can gladly chime-in and assist.
 

Poorman148

Member
May 24, 2020
7
Massachusetts
Ok, new to the forum, but I have the same problem.
when I put the filter away for the season last fall I took it apart and cleaned the inside totally.Washed all fingers with high pressure hose, not pressure wash. This spring since I returned from Florida late it was dirtier than normal. I removed as much of the debris that I could, shocked it heavily and ran the filter as I would normally. It worked for several hours and then the back pressure started pushing water out of the belly band. So I bumped and repeated. It started doing the same thing every hour. The next day, after doing tons of research I decided to clean, soak fingers in tsp overnight to remove any oils that may have accumulated on the fingers and recharged it. Same results. This morning I decided to clean it out again and soak the fingers in a solution of water and muriatic acid to remove and deposits on the inside of the tubes. Then washed tubes again, reassembled and recharged with de. Again after an hour of running the back pressure was putting water out of the belly band. I am at a loss right now. Any suggestions besides replace all 72 fingers would be appreciated. I have done everything that I know how to do. The starting pressure is about 10 psi ,then it goes to the mid thirties and blows out. When I open the filter up there is nothing on the fingers ,all the DE is at the bottom of the filter.
 
Last edited:

Poorman148

Member
May 24, 2020
7
Massachusetts
I have been opening my pool in New York. I am using a Hayward EC50AC with the fingers. The DE is not sticking to the fingers and is just settling at the bottom of the filter. I've never had this problem before. Does anyone know what might be causing the DE to not stick to the fingers?

Thanks
Did you find out what the problem was? I have the same problem.
 

pts15

New member
May 19, 2020
2
New York
15, welcome to TFP! :wave: Are you still struggling with the DE? Are you sure the DE is not making good contact with the finger while running and simply falling to the bottom when the pump is off? Figured I'd ask that silly questions first. Let us know how it's going, we have many DE fans here who can gladly chime-in and assist.
I believe the DE was likely falling to bottom as I shut off. Sort of unusual for my pool as I've not had this happen before. I let it go and things seems to be working smoothly now.