DE flowing into pool after filter cleaning

jark87

Well-known member
Jun 5, 2011
126
Flower Mound, TX
I just cleaned my filter and can see what I assume is DE flowing into my pool from the pool returns - small specs of white reflecting in the sunlight. I noticed it mostly in the spa, as the water became cloudy once I started the pool back up. I’ve had the pool for 13 years and have never seen this before. Filter pressure was only 22 psi when I cleaned it. There’s a “sock” over the what Hayward calls the flex air relief assembly that is torn, exposing what looks like a vent. It’s been torn like that for a year or two, so I doubt that’s causing the DE flow. I’ve looked at the Hayward parts diagram and they don’t show this sock, but it’s something that can easily be replaced as it is held on with a clamp. Anyone know where I can get a replacement? I should have taken a picture, but filter is reassembled now.

Should I just wait to see if the DE flow stops and clears up? Thanks for any advice!
 

jark87

Well-known member
Jun 5, 2011
126
Flower Mound, TX
Yes, and water is now completely clear. It started clearing up pretty quickly. I don’t have any idea what happened, but it seemed to be clearing up, even as I posted the original message. I don’t know if the DE that got into the pool was old DE that somehow got into the line as I was backwashing and then removing the filter or new DE after cleaning. I didn’t really look at the water until after I had added DE. I’ll be replacing the air relief assembly at the next cleaning.
 
  • Like
Reactions: DanF