DE filter started leaking after cleaning

archer636

Well-known member
Jul 6, 2016
129
Gainesville, FL
#1
it is dripping slowly from around the clamp. O-ring is lubed and clamp nut is torqued correctly.

Also, when I opened it back up I noticed that most of new DE is at the bottom, very little has got on the grids.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
10,875
Bedford, TX
#2
Archer,

DE will often slump off and fall to the bottom when new, and the filter is reopened... At least it has in my case..

How are you adding the new DE? The best way is to put it in a five gallon bucket and then add water to the bucket. I am always amazed how much water will still fit in the bucket. Stir into a really thin pancake batter and slowly pour into the skimmer, with the pump running..

I suspect the band was not tight or the O-Ring pinched.

How far was the bolt sticking through the nut? I always whack the band with a rubber mallet as I am tightening it, even though I think they say not to do that..

You really have little choice but to re-lube the O-Ring and give it another try.

Thanks,

Jim R.
 
OP
OP
A

archer636

Well-known member
Jul 6, 2016
129
Gainesville, FL
#3
Archer,

DE will often slump off and fall to the bottom when new, and the filter is reopened... At least it has in my case..

How are you adding the new DE? The best way is to put it in a five gallon bucket and then add water to the bucket. I am always amazed how much water will still fit in the bucket. Stir into a really thin pancake batter and slowly pour into the skimmer, with the pump running..

I suspect the band was not tight or the O-Ring pinched.

How far was the bolt sticking through the nut? I always whack the band with a rubber mallet as I am tightening it, even though I think they say not to do that..

You really have little choice but to re-lube the O-Ring and give it another try.

Thanks,

Jim R.
I ordered a new O-ring- see what happens.

One thing I noticed is that when I add DE (using the bucket method) the pressure does not really go up. Is it not supposed to go up?
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
10,875
Bedford, TX
#4
archer,

You know, I've never checked when running without DE?????

I have a couple of DE filters at rent houses and they both run about 10 PSI with fresh DE..

Jim R.