DE Filter questions

fmercury84

Member
May 13, 2022
18
New Jersey
Last October I paid a pool company to winterize the pool (took filter apart and rinsed) and the same company reopened it this month (added DE) after which I started the SLAM process. I got the FC/TC levels right but was never able to get rid of some pool cloudiness.
A couple of backwashes and vacuums (through filter) later I realized that the cloudiness/dust accumulating at the bottom of the pool was actually DE getting back in through the return line.
The filter pressure never seemed to increase no matter running it 24/7. I opened it up to take a look, only to find the filter full of pebbles/grains that (to me) do not look at all what a DE covered filter grid should look like. See photo.
What's going on? I am second guessing the pool maintenance company that I've used. Could this be too much DE? Or too little? After every backwash I used 80% of the full capacity (4lbs for my DEV48).
 

Attachments

  • IMG_5507.jpg
    IMG_5507.jpg
    541.5 KB · Views: 45

JoyfulNoise

TFP Expert
Platinum Supporter
May 23, 2015
21,059
Tucson, AZ
Pool Size
16000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
That looks more like pool sand for a sand filter than DE ... I'm wondering if someone screwed up and put filter sand in your DE filter :eek:

The fix is simple but not easy ... that filter needs to be taken apart, cleaned to remove all the DE and whatever that debris is and then put back together again. All of the grids and fabric needs to be checked for tears and any internal o-rings need to be inspected and lubed. Then it all has to be reassembled and loaded back up with DE.
 

fmercury84

Member
May 13, 2022
18
New Jersey
I was gonna suggest that but I have never seen a sand filter before...Thanks for your feedback and wow, I am 100% sure I only used DE and when I watched them open the pool I had no reason to believe that was something else. But at least it explains the dust in my return lines...
 

fmercury84

Member
May 13, 2022
18
New Jersey
That looks more like pool sand for a sand filter than DE ... I'm wondering if someone screwed up and put filter sand in your DE filter :eek:

The fix is simple but not easy ... that filter needs to be taken apart, cleaned to remove all the DE and whatever that debris is and then put back together again. All of the grids and fabric needs to be checked for tears and any internal o-rings need to be inspected and lubed. Then it all has to be reassembled and loaded back up with DE.
Ok I got this far…all taken apart, grids cleaned, emptied out all the sand from filter, reassembled. No evident tear on the grids or o-rings.
Of course, I ran out of DE in my previous attempts and the local store is out of stock for at least a few days.
My next problem is vacuuming the sand from the bottom of the pool. My valve only has filter/backwash positions, so how can I vacuum to waste?
In any case, I assume I should not even try to run the filter until I can feed the required amount of DE through the skimmer.
 

Poolbreh

In The Industry
Jul 31, 2021
1,019
San Diego
double checking is up to you, the DE was getting through from somewhere and it looks like a crack to me. You need a mpv to vac to waste. Just vac it up like you normally do and backwash as needed.
 
Last edited:
  • Like
Reactions: Oly

Enjoying this content?

Support TFP with a donation.

Give Support

fmercury84

Member
May 13, 2022
18
New Jersey
You were on point about the crack. It went completely unnoticed to me from rinsing distance, but the again I don’t know what I’m looking at…thank you!
So I suppose nothing can happen at this point until I get a replacement.
Does it need to be the same brand or are these manifold standard?
3E6021A7-7CAA-4B54-905E-9B271AD8739C.jpeg
 

Attachments

  • 0E678889-6F0E-448B-AC30-52EABA4E545A.jpeg
    0E678889-6F0E-448B-AC30-52EABA4E545A.jpeg
    294.1 KB · Views: 12
  • Like
Reactions: JoyfulNoise and Oly

fmercury84

Member
May 13, 2022
18
New Jersey
I just wanted to thank all those who helped on this and another thread I made previously. It only took a couple of days with the new filter manifold and the water is finally as clear as ever.
Attached before/after for your (my) enjoyment & proof 🙏🏻🙏🏻
 

Attachments

  • EB925A86-F1E5-4347-86AD-65397CD5C0E3.jpeg
    EB925A86-F1E5-4347-86AD-65397CD5C0E3.jpeg
    530.8 KB · Views: 10
  • 5A109F9F-C0E0-42A0-95B8-1584FF6AA79B.jpeg
    5A109F9F-C0E0-42A0-95B8-1584FF6AA79B.jpeg
    568.6 KB · Views: 10
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread