Cwiggs

Gold Supporter
Aug 31, 2019
293
Phoenix, AZ
Pool Size
21000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Hello TFP!

Recently I noticed a lot of dirt on the bottom of my pool. We've had some monsoons recently so I figured it was just extra dirty from that. I got out the manual vacuum and started vacuuming. While vacuuming I noticed debris coming out of the returns, It looks like almost anything I suck up is making it all the way back to the returns. My assumption is there is a crack in my DE grid(s), is that a fair assumption? I haven't backwashed, or cleaned the filter for about a year and a half. My starting PSI was 17, and it's currently at 19, so I assume I didn't need to backwash?

Also can someone help me identify my DE filter; attached are the pics. I think it's a 48 sqft Pentair FNS Plus?

Thanks!
 

Attachments

  • 20190802_141056.jpg
    20190802_141056.jpg
    646.7 KB · Views: 13
  • 20191226_092612.jpg
    20191226_092612.jpg
    524 KB · Views: 13

Cwiggs

Gold Supporter
Aug 31, 2019
293
Phoenix, AZ
Pool Size
21000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus

Cwiggs

Gold Supporter
Aug 31, 2019
293
Phoenix, AZ
Pool Size
21000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
There should be a label with model numbers on the filter shell. Several parts can contribute to your problem. If the grids are old just replace the whole internal portion which is available.
There is no label on the outside. I assume the label is wore off.

I replaced 2 grids about a year and a half ago.
 

Cwiggs

Gold Supporter
Aug 31, 2019
293
Phoenix, AZ
Pool Size
21000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
I opened the filter today and found a pretty big rip in one of the grids. Looks like about a year and half ago I replaced 3 of the normal sized grids and they still look fine. I'm going to replace the rest of the grids.
 

Cwiggs

Gold Supporter
Aug 31, 2019
293
Phoenix, AZ
Pool Size
21000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Hello TFP!

I cleaned my DE filter today and noticed one of the new grids I replaced about a year and a half ago has a pretty big stain on it. Other than the stain the grid seems fine. Is this stain something I should be worried about?

Thanks!
 

Attachments

  • 20210725_125313(1).jpg
    20210725_125313(1).jpg
    271.8 KB · Views: 3
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread