D1 Hot Tub Help

May 20, 2021
6
Rochester NY
Short version of the story…
Bought a house, had this D1 already, previous owners claimed they didn’t live here (which I believe due to other items found around house) and had the tub winterized and drained about 4 yrs ago. My wife and I figured cool, free hot tub, I thoroughly clean it, scrub it, change all o-rings, reconnect all piping, turn it on, lights work, pump works, and then seconds later the magic smoke starts escaping.

I tried finding a replacement circuit board but an internet search returns no results, emailed a company that is said to manufacturer a replacement, no response, and I’m wondering what my options are now. Local D1 seller told me to call D1, D1 says they don’t make this model anymore and a local tech should be able to help, and any tech in the area won’t touch D1 for some reason, I have no issue doing the work myself but don’t know where to locate parts. Does anyone have a website, catalog, company that they could share? So many people have told me just to cut it up and buy another but that just seems crazy to me…never owned a hot tub before so maybe that’s normal though?
 

Attachments

  • 477CEDE3-96DA-4C43-BD8C-942D65A48DEA.jpeg
    477CEDE3-96DA-4C43-BD8C-942D65A48DEA.jpeg
    313.5 KB · Views: 8

Galaxie 500

Member
May 10, 2021
17
Union, MO
Pool Size
9000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Hayward Turbo Cell (T-CELL-5)
I would look into a new spa pack so that you have a complete new main control, heater, and top side interface.
Lots of places online (like spadepot) will help you through this.
I would certainly try that path myself before junking it. Any idea where the other went south? The high voltage connections are a typical place, they get loose, pull current and overheat. I like replacing the solid copper jumper type with stranded, coated wires. Also proper torque on the lugs plus locktite is needed.
 

RDspaguy

In The Industry
Mar 21, 2020
1,455
Cabool, Mo
Post a pic of the equipment area and circuit board.
In all likelihood, those parts are NLA (no longer available). Older D1 controls were proprietary (made special for D1) and only available through D1 or an authorized distributor. Once they change control brands, or change spa functions, the old ones are no longer being built. Then the price goes up as remaining supplies go down. Once they are gone, they are gone for good.

would look into a new spa pack so that you have a complete new main control, heater, and top side interface.
Not so easy on a D1, the proprietary parts are often non-standard and difficult to find anything that will fit or work with the equipment used in an aftermarket pack.
board, pump 1 low is the connection where the board smoked
If that is the case, you can likely get it repaired by an electronics/computer repair shop pretty cheap.

that the source of my problem is the circuit board and/or pump 1.
Is it a 2 pump spa? Can you plug pump 1 into the pump 2 plug for testing?
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread