Converting from Easytouch remote to Screenlogic

nomonc

New member
Mar 31, 2021
1
Florida
Hi All,

I have an Easytouch8 control center with 4 button Easytouch remote. The remote had been working for 6+ years with no issue but is now showing No Comm. I've tried power reset (from the house breaker), relearning the addresses, and verified all the wiring connections are good. Looking at the antenna LED's - I've got good power LED, RF LINK blinks with some of the button presses on the remote, but 485 LINK never blinks - so it doesn't seem like the antenna is taking back the control center.

Based on the research here seems like the SL is the way to go instead of trying to replace the antenna (but i'm open to further suggestions on any fixes to get the existing equipment back to working). Other than changing the temps on the heaters (solar/gas) or going from pool to spa, I really don't have any programming that I do, so the simplicity of the remote was ok with me.

Now specifically about the SL setup. PN 522104 is the kit I would need. The 4 wire would go from the Easytouch center J20 block to the 4 wire in the outside transmitter. The Protocol adapter would connect via ethernet to the home network, then to the inside wireless with the supplied cable adapter. Is there any firmware versions between the kit and the Easytouch control center to worry about?

Does the SL software automatically import/read the existing Easytouch settings/configs?

Thanks for all the advice.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,289
Bedford, TX
No,

I have ScreenLogic2 and love it... ScreenLogic just allows you to communicate with the EasyTouch via your PC, Phone, or Tablet.. When installed it will show whatever programs are in your main board.. It is dirt simple to install.. I installed mine and it fired right up without any issues.. Lately, we have seen "some" people with Mesh routers having an issue, but other with the same type of router, with no issues at all.

You are correct in how the ScreenLogic components are installed. As far as I know the EasyTouch F/W does not make any difference.

I get screens like these on my PC.. I hardly ever use my phone.. Programing using ScreenLogic is about 10 X easer and more intuitive..






Thanks,

Jim R.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,289
Bedford, TX
B,

Something is wrong.. I've been using ScreenLogic for about 7 years and have never had any connection issues..

Just from reading here, often just moving the inside receiver a few feet away from other electronics, can make a big difference in operation.

Thanks,

Jim R.
 

bnsfengineer

New member
May 11, 2021
3
So Ca
B,

Something is wrong.. I've been using ScreenLogic for about 7 years and have never had any connection issues..

Just from reading here, often just moving the inside receiver a few feet away from other electronics, can make a big difference in operation.

Thanks,

Jim R.
Hey Jim is the app the ScreenLogic Connect that was last updated 9-30-18 in the google play store. If so can you tell me why it will never display a Salt Level? It displays Pool and Spa output and I can adjust it but my salt level always displays 0 any ideas or help I would greatly appreciate!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
21,289
Bedford, TX
B,

That is an EasyTouch issue and not a ScreenLogic issue.. If you look in the ET's Diagnostic menu, you will see that it also shows zero.

It is a com problem between the cell and the EasyTouch.. It is really a timing issue.. There is a short delay between the time the screen comes on and the time the display updates.. Almost any change in the timing will make it work, or not work. It has been fixed by replacing the flow switch, the entire cell, the surge card (cell's power supply inside the EasyTouch) and even the main board in the EasyTouch. If not under warranty, I'd start with the cheapest item, the flow switch. Does not really need to be fixed as long at the salt light on the cell is working. If still in warranty, just have Pentair come out and fix it. It is a well known issue.

I "almost" have the same issue.. About once out of every 100 times I look at the IntelliChlor page it will show a salt level of zero.. Sometimes it will come back after just going out and back into the same page.. Once in a while I have to reboot the ET.. The other 99 times it works just like it should. :rolleyes:

Thanks,

Jim R.
 

bnsfengineer

New member
May 11, 2021
3
So Ca
B,

That is an EasyTouch issue and not a ScreenLogic issue.. If you look in the ET's Diagnostic menu, you will see that it also shows zero.

It is a com problem between the cell and the EasyTouch.. It is really a timing issue.. There is a short delay between the time the screen comes on and the time the display updates.. Almost any change in the timing will make it work, or not work. It has been fixed by replacing the flow switch, the entire cell, the surge card (cell's power supply inside the EasyTouch) and even the main board in the EasyTouch. If not under warranty, I'd start with the cheapest item, the flow switch. Does not really need to be fixed as long at the salt light on the cell is working. If still in warranty, just have Pentair come out and fix it. It is a well known issue.

I "almost" have the same issue.. About once out of every 100 times I look at the IntelliChlor page it will show a salt level of zero.. Sometimes it will come back after just going out and back into the same page.. Once in a while I have to reboot the ET.. The other 99 times it works just like it should. :rolleyes:

Thanks,

Jim R.
Thanks Jim for the info, and yes the light comes on the salt gen as I replaced couple years ago but the system is over ten years old.. just have to look at the lights on the generator from time to time!