Converting from Easytouch remote to Screenlogic

nomonc

New member
Mar 31, 2021
1
Florida
Hi All,

I have an Easytouch8 control center with 4 button Easytouch remote. The remote had been working for 6+ years with no issue but is now showing No Comm. I've tried power reset (from the house breaker), relearning the addresses, and verified all the wiring connections are good. Looking at the antenna LED's - I've got good power LED, RF LINK blinks with some of the button presses on the remote, but 485 LINK never blinks - so it doesn't seem like the antenna is taking back the control center.

Based on the research here seems like the SL is the way to go instead of trying to replace the antenna (but i'm open to further suggestions on any fixes to get the existing equipment back to working). Other than changing the temps on the heaters (solar/gas) or going from pool to spa, I really don't have any programming that I do, so the simplicity of the remote was ok with me.

Now specifically about the SL setup. PN 522104 is the kit I would need. The 4 wire would go from the Easytouch center J20 block to the 4 wire in the outside transmitter. The Protocol adapter would connect via ethernet to the home network, then to the inside wireless with the supplied cable adapter. Is there any firmware versions between the kit and the Easytouch control center to worry about?

Does the SL software automatically import/read the existing Easytouch settings/configs?

Thanks for all the advice.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
25,932
Bedford, TX
No,

I have ScreenLogic2 and love it... ScreenLogic just allows you to communicate with the EasyTouch via your PC, Phone, or Tablet.. When installed it will show whatever programs are in your main board.. It is dirt simple to install.. I installed mine and it fired right up without any issues.. Lately, we have seen "some" people with Mesh routers having an issue, but other with the same type of router, with no issues at all.

You are correct in how the ScreenLogic components are installed. As far as I know the EasyTouch F/W does not make any difference.

I get screens like these on my PC.. I hardly ever use my phone.. Programing using ScreenLogic is about 10 X easer and more intuitive..




View media item 1963

Thanks,

Jim R.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
25,932
Bedford, TX
B,

Something is wrong.. I've been using ScreenLogic for about 7 years and have never had any connection issues..

Just from reading here, often just moving the inside receiver a few feet away from other electronics, can make a big difference in operation.

Thanks,

Jim R.
 

bnsfengineer

Member
May 11, 2021
11
So Ca
B,

Something is wrong.. I've been using ScreenLogic for about 7 years and have never had any connection issues..

Just from reading here, often just moving the inside receiver a few feet away from other electronics, can make a big difference in operation.

Thanks,

Jim R.
Hey Jim is the app the ScreenLogic Connect that was last updated 9-30-18 in the google play store. If so can you tell me why it will never display a Salt Level? It displays Pool and Spa output and I can adjust it but my salt level always displays 0 any ideas or help I would greatly appreciate!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
25,932
Bedford, TX
B,

That is an EasyTouch issue and not a ScreenLogic issue.. If you look in the ET's Diagnostic menu, you will see that it also shows zero.

It is a com problem between the cell and the EasyTouch.. It is really a timing issue.. There is a short delay between the time the screen comes on and the time the display updates.. Almost any change in the timing will make it work, or not work. It has been fixed by replacing the flow switch, the entire cell, the surge card (cell's power supply inside the EasyTouch) and even the main board in the EasyTouch. If not under warranty, I'd start with the cheapest item, the flow switch. Does not really need to be fixed as long at the salt light on the cell is working. If still in warranty, just have Pentair come out and fix it. It is a well known issue.

I "almost" have the same issue.. About once out of every 100 times I look at the IntelliChlor page it will show a salt level of zero.. Sometimes it will come back after just going out and back into the same page.. Once in a while I have to reboot the ET.. The other 99 times it works just like it should. :rolleyes:

Thanks,

Jim R.
 

bnsfengineer

Member
May 11, 2021
11
So Ca
B,

That is an EasyTouch issue and not a ScreenLogic issue.. If you look in the ET's Diagnostic menu, you will see that it also shows zero.

It is a com problem between the cell and the EasyTouch.. It is really a timing issue.. There is a short delay between the time the screen comes on and the time the display updates.. Almost any change in the timing will make it work, or not work. It has been fixed by replacing the flow switch, the entire cell, the surge card (cell's power supply inside the EasyTouch) and even the main board in the EasyTouch. If not under warranty, I'd start with the cheapest item, the flow switch. Does not really need to be fixed as long at the salt light on the cell is working. If still in warranty, just have Pentair come out and fix it. It is a well known issue.

I "almost" have the same issue.. About once out of every 100 times I look at the IntelliChlor page it will show a salt level of zero.. Sometimes it will come back after just going out and back into the same page.. Once in a while I have to reboot the ET.. The other 99 times it works just like it should. :rolleyes:

Thanks,

Jim R.
Thanks Jim for the info, and yes the light comes on the salt gen as I replaced couple years ago but the system is over ten years old.. just have to look at the lights on the generator from time to time!
 

Telemachus

Well-known member
Dec 7, 2014
95
Riverside
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
The only part of the screenlogic system that is really needed is the protocol adapter. There are MUCH cheaper and more powerful ways to access your network than Pentairs antiquated wireless connection. I stuck my protocol adapter in the low voltage area of my easytouch with a tiny $20 router/access point and it worked fine.

More info here:

Then I setup my njs-poolController and the difference was night and day.

1) The entire setup costs less than $50 and has a MUCH smaller footprint, especially when using a Raspberry pi zero w.
2) You can access it from any browser without depending on Pentairs app or servers. Apple watch, PC, phone... all work.
3) You can integrate with other home automation systems for Siri, Alexa, Google etc.
Also, can connect to other devices to read your pool chemistry, etc.
4) You get developers who actively support and debug. Good luck getting pentair to help you with your screenlogic when it stops communicating.
5) you think programming with SL2 is easy? Wait until you try this. It's basically tap the setting and make changes.

What's the downside?
1) If you aren't familiar with Linux, or Raspberry Pis, you'll be in for some reading.
2) Password protection is not yet integrated. So if you want access away from your home network you'll have to open a port to the general world (while I would NOT recommend) or setup a VPN.

Extensive info here:


P.S. Jim, for all the help you give everyone here, I'd love to help you setup an njs-pC setup. I think you would promptly sell the SL2
 

Attachments

  • 125399.jpeg
    125399.jpeg
    64.5 KB · Views: 8
  • 20210510_104037.jpg
    20210510_104037.jpg
    172.4 KB · Views: 9
Last edited:
  • Like
Reactions: ogdento

bnsfengineer

Member
May 11, 2021
11
So Ca
I need help that I posted on another thread with no response yet. I had installed the screen logic a few years back after my remote died and been using strictly phone or iPad and its worked fairly well. However had a friend fix the remote which was just a broken battery box and now all I get is the "No Comm" I tried going through the steps for the Wireless Address and it just keeps searching for it? I start at the equipment and then the remote. The question is did I make a mistake when I installed the Screen Logic and removed the old antenna and installed the one that came with the new kit? When someone has both Easy Touch remote and Screen Logic are there 2 antennas? As you can probably tell I'm Technically Challenged!:rolleyes:
 

Telemachus

Well-known member
Dec 7, 2014
95
Riverside
Pool Size
20000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
Yes. There are two.

My understanding is that Each transmitter is "married" to its receiver. If one goes bad, you have to replace both.

If you still have it you could wire it to the com port in the same housing (if it fits).

Alternatively, you could potentially wire it directly to the protocol adapter inside the house. Wireless remote would transmit to the antenna by your router, that would then get transmitted by other antenna to your pool equipment.
 

Enjoying this content?

Support TFP with a donation.

Give Support
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread