Connecting to ScreenLogic Remotely

Stoopalini

Gold Supporter
Jun 8, 2020
434
Central Texas
When we initially installed the ScreenLogic setup, I used my phone to connect to it remotely (ie: I shut my phone's WiFi off, and connected over the WWW VIA the cell network), and it worked fine to connect and run through initial config and also to control the pump, lights, etc ...

Since then, I've been connecting locally (while on my home's WiFi) and all has been fine.

Well, today ... while at church ... my wife made a comment "I'd really like to swim today, I wonder what the water temp is?" ... so I thought, -I can answer that :) Just log into ScreenLogic ... but when I tried, I get "ERROR: Cannot connect"

I've tried several times, and it hangs on "Requesting gateway connection " for a minute or so, then displays the error. Prior to hanging on "Requesting gateway connection", I can see other messages flashing, but it's too fast to be able to read them.

I've already tried unplugging and replugging the power to the protocol adapter, and it hasn't worked. I have a static IP address assigned to it in my router as well.

I realize the protocol adapter phones home to Pentair, and reports the public IP of my router, and then uses this to allow remote connection. I'm not sure if my ISP has changed my public IP between the time we set this up until today, but even if they did, I would think resetting the protocol adapter would cause it to phone home again and update the IP address.

Anyone have any ideas? Considering I was able to connect on day 1, I don't think this is a firewall or router config issue; but am open to suggestions.
 

ivparker

Bronze Supporter
Aug 28, 2016
96
Byron Center, MI
Is it possible that it’s something wrong on the Pentair side? The exact thing happened to us today but our problem is we never could get the local to work. So even though we are home, we can’t use our ScreenLogic. My husband has messed with it for a few hours already today. He is a IT guy, still doesn’t work. Worked fine yesterday. Same thing with very fast words. I think it says “ connecting to discovery service.”
 

TimR

Member
Aug 14, 2008
5
League City (Houston), TX
My Screenlogic is also not working today on neither my PC nor on my Android phone app. Initially I was thinking it was a problem with my home network (and it still may be), but I also noticed that I can't even connect to the "Demo Server" through my phone app which makes me think maybe it is something on Pentair's end.

Can anyone confirm if Screenlogic is working for them to their pool and also able to connect to the Demo Server?

The system seems pretty finicky so I'm leery of resetting it all if I'm not sure the problem is on my end.

Thanks.
 

TimR

Member
Aug 14, 2008
5
League City (Houston), TX
I just tested, and it's working for me again as well. Must have been a Pentair service failure over the weekend.
Hmmmm. Still not working for me.

On my PC nothing shows up in the Local Systems box. When I click on the Start ScreenLogic button a "Connecting to Remote System" window pops up and reads:
Discovery Service: XXX.XX.XX.XX:XXX {XXs are mine, actually shows a legitimate address}​
Connecting to Discovery Service...​
Connected.​
Sending GATEWAY remote connection request...​
Remote connection authorized.​
Found system at :0.​
Connecting to System at :0...​
Direct connection failed.​
ERROR: Cannot connect. Address invalid​
With a Cancel button (which does nothing).​

On my phone app nothing shows up as local. My pool and the demo server show up under Remote connections, but when I click on either of those I get the following error message:
ScreenLogic​
Login failed. Please check:​
Password​
Wifi or cellular data is enable.​


We had a storm over the weekend that seems to have killed my network switch. After that is when I first noticed that ScreenLogic wasn't working. I replace the switch and also tried connecting directly an open port on my router. Neither worked (and also I don't see how that would affect my phone app from connecting to the demo server). I'm worried that the whatever killed my switch, also killed something in the ScreenLogic hardware, but again if that was the case I wouldn't think that would affect my being able to connect to the demo server.

Any thoughts what I should try? Is the demo server actually still working?

Thanks,
Tim