Connecting the Intelliflo pump to the Intellitouch com ports

BadDogPSD

Gold Supporter
May 24, 2020
146
Reno, NV
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
I've recently swapped out our single speed pump in favor of an Intelliflo VS (011028) and added a Circupool RJ60+ SWG. Everything is up and running except I need to connect the pump to the
Intellitouch com ports. The Intellitouch has the i9 plus 3 personality board.
I found an online manual that indicates com ports J7 & J8, green wire to terminal 2, yellow wire to terminal 3. Does this sound correct?
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,554
Bedford, TX
Dog,

That is correct.. There are only two wires in the cable, Green and Yellow... The J7/J8 connectors are also marked color coded Green and Yellow..

Just make sure you have no power on anything when screwing with com port connections.

You will then need to set schedules for when you want the Pool or Spa Circuits to run.. And will need to set up pump speeds for Pool and Spa and whatever other speeds you want to run.

Do you have ScreenLogic?? If so here is the speed set up page...




Thanks,

Jim R.
 

BadDogPSD

Gold Supporter
May 24, 2020
146
Reno, NV
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Thanks again Jim! Got the wires hooked up, but looks like I need to name the new pump.

Edit to add: No Screen Logic yet.
 
Last edited:

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,554
Bedford, TX
Dog,

You don't need to name the pump.. You don't schedule the "pump" you schedule either the Pool Circuit or the Spa Circuit..

Then you assign the speeds you want the pump to run..

The basic concept is to use the slowest speed you want to run for the Pool mode.. Then use Feature Circuits to "add" different speeds.. The pump will always run the fastest speed it sees..

Here is a simple example... A total useless set of schedules just to show how they work...

Pool - 1200 RPM Scheduled 8 am until 8 pm (Notice that the Pool or Spa circuit needs to be on the entire time you want the pump to run..)
Skim Low - 1500 RPM.. (This is a Feature Circuit).. Schedule 9 am until 11 am..
Skim High - 2000 RPM.. (another Feature Circuit).. Schedule 10 am until 10:30 am
Waterfall - 2800.. (yet another Feature Circuit).. Schedule 1 pm until 2 pm...

The pump comes on at 8 am at 1200 RPM, until 9 am when Skim Low comes on the the pump increase speed to 1500. It stays at this speed until 10 am when Skim High comes on and the speed goes up to 2000 RPM. At 10:30 skim high shuts off and the pump goes back to 1500 until 11 am when skim low shuts off and the speed goes back to 1200 RPM.. At 1 pm the Waterfall circuit comes on and the speed goes up to 2800 until 2 pm when the speed drops back to 1200 RPM.. It will run at 1200 until 8 pm when the pump shuts off..

Let me know if that is not clear as mud... :mrgreen:

Jim R.
 

BadDogPSD

Gold Supporter
May 24, 2020
146
Reno, NV
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
@Jimrahbe I'm thinking I might need to be in the remedial class! I can't figure out how to program & connect the Feature Circuits to the pump...
 

Attachments

  • Intellitouch Control 1.jpg
    Intellitouch Control 1.jpg
    326.7 KB · Views: 6
  • Intellitouch Control 2.jpg
    Intellitouch Control 2.jpg
    362.8 KB · Views: 6

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,554
Bedford, TX
Craig,

I assume the IntelliTouch is very similar to the EasyTouch..

You have a set of "Circuits" that every system comes with... Pool, Spa, Aux 1 thru 8, Feature Circuits 1-8..

Each Circuit can have one and only one pump speed...

You have to tell the IntelliTouch the speed you want each circuit to run..

If you look back at my set up, you can see where Pool is set to run at 1250 RPM.
Then you can see where I have two feature circuits that I named Skim Low at 1500 RPM and Skim High at 2000 RPM..

You should have something like this under.. Menu, Settings, IntelliFlo, Speeds.. You should be able to add a speed to each circuit.. (Depending on the age of your system, it will be limited to 4 or 8 speeds.

Let me know if you find it..

Thanks,

Jim R.
 

BadDogPSD

Gold Supporter
May 24, 2020
146
Reno, NV
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
Still not seeing it Jim, I wonder if my system is too dated??? I think it was installed in 2005 and doubt it's ever been updated.
 

Enjoying this content?

Support TFP with a donation.

Give Support

BadDogPSD

Gold Supporter
May 24, 2020
146
Reno, NV
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-60 Plus
If you go to Setup, do you see an Equipment option? You should be able to get to intelliflo through that. I'm not near my system so this is coming from memory... grab the manual from the pentair site if you still can't find it
Here's what I see when I go Menu>SETUP>EQUIPMENT
 

Attachments

  • 20210815_195058.jpg
    20210815_195058.jpg
    305.5 KB · Views: 7

ogdento

Bronze Supporter
Mar 30, 2015
738
Chico, CA
Hey Craig,
Yeah, you need a firmware update... if you've got a local shop that does pentair stuff they should be able to come out and do it for you (the fee varies wildly). If not you'll have to send the mainboard AND indoor remote to somebody to update, or give it a crack yourself (there's a TFP thread explaining how to do it). I can't do it until October, but I know @jerryt has done some intellitouch updates as well.
While you're waiting for the update, you can program schedules on the pump itself and it will run them - just won't be connected to the intellitouch.
Tom
 
  • Like
Reactions: BadDogPSD
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread