cloud water when SWG is turned on

Gar2

New member
May 27, 2012
3
Pool was recently opened. When adding Purity Resist to the raise the alkainity and salt, the water began to foam and turn milky. with in a hour, it cleared. The water is sparkling clean, but when I turn on the SWG, it pours out cloud water. any ideas.
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
Welcome to TFP!

The cloudiness is made from a large number of tiny bubbles. The SWG produces hydrogen gas when it is running. Normally this gas forms slightly larger bubbles that rise to the surface and pop and are never easily seen. But when the water conditions are just right very small bubbles will form creating cloudiness just as you describe.

If you balance all of your levels and wait a day or two the cloudiness will stop. In the mean time, it is purely visual and has no effect on the water or your chemical balance.
 

Gar2

New member
May 27, 2012
3
thanks guys.. the water was balanced. this happened a couple of years ago and I had to drain some water & refill, but not sure if we used a different alkainithy product or not. any suggestion on how long this will continue and will it hurt the SWG cel?
thanks
 

JasonLion

TFP Expert
Platinum Supporter
LifeTime Supporter
May 7, 2007
37,880
Silver Spring, MD
This isn't at all common, so we don't have too many examples to go by. But so far it has never lasted more than a couple of days for anyone who has posted on the forum and so far has only happened when the water was cold and the CYA level quite low.

There is no risk/damage to the SWG. This is all completely normal from it's point of view.
 

Gar2

New member
May 27, 2012
3
thanks for all your help.. I will wait a couple of day and try again. I'll close for now and let you know how it turned out..Take care